summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Paden2015-07-16 22:39:01 -0500
committerAaron Paden2015-07-16 22:39:01 -0500
commit94c001a783ff9607cf28ce29cbd74cacfdf42ba7 (patch)
treee4b0f835b7539f013ceae0eff4c6eeffe6c04e71
downloadaur-94c001a783ff9607cf28ce29cbd74cacfdf42ba7.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eecd5c789216
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oosbuild
+ pkgdesc = Build an autoconf project out of source
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/BPaden/oosbuild
+ arch = any
+ license = GPL2
+ depends = python
+ depends = python-docopt
+ source = https://github.com/BPaden/oosbuild/archive/1.0.tar.gz
+ sha256sums = 8ace8d822c8ff2c51f9f58eacc65caac98060253fce3026b9df0352895b33a28
+
+pkgname = oosbuild
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0c95227b27f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Aaron Paden <aaronbpaden@gmail.com>
+pkgname=oosbuild
+pkgver=1.0
+pkgrel=1
+pkgdesc="Build an autoconf project out of source"
+arch=(any)
+url="https://github.com/BPaden/oosbuild"
+license=('GPL2')
+depends=('python' 'python-docopt')
+source=("https://github.com/BPaden/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('8ace8d822c8ff2c51f9f58eacc65caac98060253fce3026b9df0352895b33a28')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}