summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMicael Bergeron2017-09-13 12:45:45 -0400
committermicael.bergeron2017-09-13 12:49:01 -0400
commitdbff56627bf84222e830a12446d6c1defea217b4 (patch)
treecd364a8baef602167b16c9bba0c1657223b39e3d
downloadaur-dbff56627bf84222e830a12446d6c1defea217b4.tar.gz
add op: the 1Password CLI
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51605828750d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = op-bin
+ pkgdesc = 1Password CLI
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://app-updates.agilebits.com/product_history/CLI
+ arch = i686
+ arch = x86_64
+ arch = arm
+ license = UNLICENSED
+ provides = op
+ source_i686 = https://cache.agilebits.com/dist/1P/op/pkg/v0.1.1/op_linux_386_v0.1.1.zip
+ md5sums_i686 = 1818e539d28b34ea338024e99f3f6472
+ source_x86_64 = https://cache.agilebits.com/dist/1P/op/pkg/v0.1.1/op_linux_amd64_v0.1.1.zip
+ md5sums_x86_64 = 8123b36d28817c64a3faa13a582cb191
+ source_arm = https://cache.agilebits.com/dist/1P/op/pkg/v0.1.1/op_linux_arm_v0.1.1.zip
+ md5sums_arm = dca7bf7ba56b7911f0800452a4034535
+
+pkgname = op-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62a2ec0ff1c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+_pkgbasename=op
+pkgname=$_pkgbasename-bin
+pkgver=0.1.1
+pkgrel=1
+epoch=
+pkgdesc="1Password CLI"
+arch=('i686' 'x86_64' 'arm')
+url="https://app-updates.agilebits.com/product_history/CLI"
+license=('UNLICENSED')
+provides=('op')
+source_x86_64=("https://cache.agilebits.com/dist/1P/$_pkgbasename/pkg/v$pkgver/op_linux_amd64_v${pkgver}.zip")
+md5sums_x86_64=('8123b36d28817c64a3faa13a582cb191')
+source_i686=("https://cache.agilebits.com/dist/1P/$_pkgbasename/pkg/v$pkgver/op_linux_386_v${pkgver}.zip")
+md5sums_i686=('1818e539d28b34ea338024e99f3f6472')
+source_arm=("https://cache.agilebits.com/dist/1P/$_pkgbasename/pkg/v$pkgver/op_linux_arm_v${pkgver}.zip")
+md5sums_arm=('dca7bf7ba56b7911f0800452a4034535')
+
+check() {
+ gpg --verify-files ${srcdir}/op.sig
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+
+ cp "${srcdir}/op" \
+ "${pkgdir}/usr/bin/op"
+}