summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexandruianu2015-07-19 21:25:56 +0300
committeralexandruianu2015-07-19 21:25:56 +0300
commite57ad1493efed04bee168265f7e25c1a59d4a6ef (patch)
tree32320d0f8ec52893452445ec6f8922c8248ee5e5
parentff6c3adf9edeeffe90455ae6ece9f6779b13e4c6 (diff)
downloadaur-e57ad1493efed04bee168265f7e25c1a59d4a6ef.tar.gz
term script and man page
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
3 files changed, 25 insertions, 35 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 16e003c2f780..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,16 +0,0 @@
-pkgbase = open-fuse-iso
- pkgdesc = Automatic userspace mounting/unmounting of image files through the open-iso script
- pkgver = 1.0
- pkgrel = 5
- url = http://forum.manjaro.org/index.php?topic=9306.0
- install = open-fuse-iso.install
- arch = any
- license = GPL
- makedepends = binutils
- depends = fuseiso
- depends = libnotify
- source = https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso
- source = https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop
-
-pkgname = open-fuse-iso
-
diff --git a/.SRCINFO b/.SRCINFO
index e178ef339feb..1c1c34a0372d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = open-fuse-iso
- pkgdesc = Automatic userspace mounting/unmounting of image files through the open-iso script
- pkgver = 1.0
- pkgrel = 5
+ pkgdesc = Rapid image mounting/unmounting in userspace using fuseiso.
+ pkgver = 1.1
+ pkgrel = 1
url = http://forum.manjaro.org/index.php?topic=9306.0
install = open-fuse-iso.install
arch = any
@@ -9,10 +9,10 @@ pkgbase = open-fuse-iso
makedepends = binutils
depends = fuseiso
depends = libnotify
- source = https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso
- source = https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop
- md5sums = 6629c2213e9a1d51942ef2c08d849730
- md5sums = e784d7f56586b3985cd9dbd0447a8f37
+ provides = open-fuse-iso-term
+ conflicts = open-fuse-iso-term
+ source = open-fuse-iso::git+https://github.com/alexandruianu/open-fuse-iso
+ md5sums = SKIP
pkgname = open-fuse-iso
diff --git a/PKGBUILD b/PKGBUILD
index 2690e69ff2b9..811b704c36b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: alexandru.ianu@gmail.com
pkgname=open-fuse-iso
-pkgver=1.0
-pkgrel=5
-pkgdesc="Automatic userspace mounting/unmounting of image files through the open-iso script"
+pkgver=1.1
+pkgrel=1
+pkgdesc="Rapid image mounting/unmounting in userspace using fuseiso."
arch=('any')
url="http://forum.manjaro.org/index.php?topic=9306.0"
license=('GPL')
@@ -11,20 +11,26 @@ depends=('fuseiso'
'libnotify')
makedepends=('binutils')
#optdepends=('')
-#conflicts=('')
-#provides=('')
+conflicts=('open-fuse-iso-term')
+provides=('open-fuse-iso-term')
#replaces=('')
-install="$pkgname".install
-source=("https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso"
- "https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop")
-md5sums=('6629c2213e9a1d51942ef2c08d849730'
- 'e784d7f56586b3985cd9dbd0447a8f37')
+source=("$pkgname::git+https://github.com/alexandruianu/$pkgname")
+install="${pkgname}.install"
+md5sums=('SKIP')
package() {
+ cd $srcdir/$pkgname
mkdir -p "$pkgdir/usr/bin/"
- cp "$srcdir/open-fuse-iso" "$pkgdir/usr/bin/open-fuse-iso"
+ cp ofi "$pkgdir/usr/bin/ofi"
+ cp ofit "$pkgdir/usr/bin/ofit"
+ cp open-fuse-iso "$pkgdir/usr/bin/open-fuse-iso"
+ chmod +x "$pkgdir/usr/bin/ofi"
+ chmod +x "$pkgdir/usr/bin/ofit"
chmod +x "$pkgdir/usr/bin/open-fuse-iso"
mkdir -p "$pkgdir/usr/share/applications"
- cp "$srcdir/open-fuse-iso.desktop" "$pkgdir/usr/share/applications/open-fuse-iso.desktop"
+ cp open-fuse-iso.desktop "$pkgdir/usr/share/applications/open-fuse-iso.desktop"
chmod +x "$pkgdir/usr/share/applications/open-fuse-iso.desktop"
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ cp man1/open-fuse-iso.1 "$pkgdir/usr/share/man/man1/open-fuse-iso.1"
+ gzip "$pkgdir/usr/share/man/man1/open-fuse-iso.1"
}