summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexandruianu2015-06-25 15:54:54 +0300
committeralexandruianu2015-06-25 15:54:54 +0300
commitff6c3adf9edeeffe90455ae6ece9f6779b13e4c6 (patch)
treee1a59ddb1b2463affb86723c6cdc89a388c96b0f
downloadaur-ff6c3adf9edeeffe90455ae6ece9f6779b13e4c6.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--open-fuse-iso.install14
4 files changed, 78 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..16e003c2f780
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = open-fuse-iso
+ pkgdesc = Automatic userspace mounting/unmounting of image files through the open-iso script
+ pkgver = 1.0
+ pkgrel = 5
+ url = http://forum.manjaro.org/index.php?topic=9306.0
+ install = open-fuse-iso.install
+ arch = any
+ license = GPL
+ makedepends = binutils
+ depends = fuseiso
+ depends = libnotify
+ source = https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso
+ source = https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop
+
+pkgname = open-fuse-iso
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e178ef339feb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = open-fuse-iso
+ pkgdesc = Automatic userspace mounting/unmounting of image files through the open-iso script
+ pkgver = 1.0
+ pkgrel = 5
+ url = http://forum.manjaro.org/index.php?topic=9306.0
+ install = open-fuse-iso.install
+ arch = any
+ license = GPL
+ makedepends = binutils
+ depends = fuseiso
+ depends = libnotify
+ source = https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso
+ source = https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop
+ md5sums = 6629c2213e9a1d51942ef2c08d849730
+ md5sums = e784d7f56586b3985cd9dbd0447a8f37
+
+pkgname = open-fuse-iso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2690e69ff2b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: alexandru.ianu@gmail.com
+
+pkgname=open-fuse-iso
+pkgver=1.0
+pkgrel=5
+pkgdesc="Automatic userspace mounting/unmounting of image files through the open-iso script"
+arch=('any')
+url="http://forum.manjaro.org/index.php?topic=9306.0"
+license=('GPL')
+depends=('fuseiso'
+ 'libnotify')
+makedepends=('binutils')
+#optdepends=('')
+#conflicts=('')
+#provides=('')
+#replaces=('')
+install="$pkgname".install
+source=("https://www.dropbox.com/s/o1okqgx1apgqp8i/open-fuse-iso"
+ "https://www.dropbox.com/s/wkd70lo3at67oiv/open-fuse-iso.desktop")
+md5sums=('6629c2213e9a1d51942ef2c08d849730'
+ 'e784d7f56586b3985cd9dbd0447a8f37')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cp "$srcdir/open-fuse-iso" "$pkgdir/usr/bin/open-fuse-iso"
+ chmod +x "$pkgdir/usr/bin/open-fuse-iso"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$srcdir/open-fuse-iso.desktop" "$pkgdir/usr/share/applications/open-fuse-iso.desktop"
+ chmod +x "$pkgdir/usr/share/applications/open-fuse-iso.desktop"
+}
diff --git a/open-fuse-iso.install b/open-fuse-iso.install
new file mode 100644
index 000000000000..7c6e40cc545d
--- /dev/null
+++ b/open-fuse-iso.install
@@ -0,0 +1,14 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}