summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWasabiThumb2023-10-26 12:19:23 -0400
committerWasabiThumb2023-10-26 12:19:23 -0400
commit2dd076efbea2ebeebf1b213f9c537e6d2363cb9d (patch)
tree44abe3784d176cf627c2f029d3d37b626a8b287f
downloadaur-2dd076efbea2ebeebf1b213f9c537e6d2363cb9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD45
-rw-r--r--gensrc.sh0
-rw-r--r--maintain.py1
5 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24c90701c545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = open-goal-launcher-bin
+ pkgdesc = A launcher for the OpenGOAL Project to simplify usage and installation
+ pkgver = 2.2.2
+ pkgrel = 1
+ url = https://github.com/open-goal/launcher
+ arch = x86_64
+ license = ISC
+ depends = bash
+ conflicts = open-goal-launcher
+ source_x86_64 = https://github.com/open-goal/launcher/releases/download/v2.2.2/open-goal-launcher_2.2.2_amd64.AppImage
+ md5sums_x86_64 = eefcbcea51e66fb2c19a2a7522ae8204
+
+pkgname = open-goal-launcher-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..485dee64bcfb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+.idea
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2de89d06183f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Wasabi <wasabithumbs@gmail.com>
+pkgname=open-goal-launcher-bin
+pkgver="2.2.2"
+pkgrel=1
+pkgdesc="A launcher for the OpenGOAL Project to simplify usage and installation"
+arch=("x86_64")
+url='https://github.com/open-goal/launcher'
+license=('ISC')
+depends=('bash')
+conflicts=('open-goal-launcher')
+_image="open-goal-launcher_${pkgver}_amd64.AppImage"
+source_x86_64=("https://github.com/open-goal/launcher/releases/download/v2.2.2/${_image}")
+md5sums_x86_64=("eefcbcea51e66fb2c19a2a7522ae8204")
+
+prepare() {
+ cd $srcdir
+ chmod +x "${_image}"
+ ./"${_image}" --appimage-extract
+}
+
+build() {
+ cd "${srcdir}/squashfs-root"
+ sed -i '/^Type=/d' open-goal-launcher.desktop
+ sed -i '/^Exec=/d' open-goal-launcher.desktop
+ sed -i '/^Comment=/d' open-goal-launcher.desktop
+ sed -i '/^Version=/d' open-goal-launcher.desktop
+ sed -i '/^X-AppImage-Version=/d' open-goal-launcher.desktop
+ echo "Type=Application" >> open-goal-launcher.desktop
+ echo "Exec=/usr/bin/${pkgname}" >> open-goal-launcher.desktop
+ echo "Comment=${pkgdesc}" >> open-goal-launcher.desktop
+ echo "Version=${pkgver}" >> open-goal-launcher.desktop
+ chmod -R a-x+rX usr
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_image}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+
+ install -Dm644 "${srcdir}/squashfs-root/open-goal-launcher.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file
diff --git a/gensrc.sh b/gensrc.sh
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gensrc.sh
diff --git a/maintain.py b/maintain.py
new file mode 100644
index 000000000000..8d1c8b69c3fc
--- /dev/null
+++ b/maintain.py
@@ -0,0 +1 @@
+