summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 15:44:19 +0200
committerChristian Hesse2015-06-30 15:44:19 +0200
commit8f11e0e27c4fc691cdb7e33ef40a37fc4461641f (patch)
tree5697f248e87a09d91a5bfa5c35f0fd6c20f5a68b
downloadaur-8f11e0e27c4fc691cdb7e33ef40a37fc4461641f.tar.gz
initial import of open-lldp 0.9.46-5
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
-rw-r--r--configure.patch11
-rw-r--r--makefile.patch13
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb690988295
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = open-lldp
+ pkgdesc = Open Link Layer Discovery Protocol - LLDP Agent Daemon
+ pkgver = 0.9.46
+ pkgrel = 5
+ url = http://www.open-lldp.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libnl1
+ depends = libconfig
+ optdepends = bash-completion: command completion in bash
+ source = http://ftp-osl.osuosl.org/pub/open-lldp/open-lldp-0.9.46.tar.gz
+ source = http://ftp-osl.osuosl.org/pub/open-lldp/open-lldp-0.9.46.tar.gz.sig
+ source = configure.patch
+ source = makefile.patch
+ sha256sums = c7b4abc970bf4cc12617b8124de0b440e69fc2a9f680973d2c313301802def14
+ sha256sums = SKIP
+ sha256sums = 3459d8d8b37c188d3a837fc9fb91d9680294c22f1cf6a27cd66b3b3b89667971
+ sha256sums = fa43952bf89146f6d584a56f593f4268926cbc60a20bb8972e134a1506f8db13
+
+pkgname = open-lldp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bc902f1c372
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=open-lldp
+pkgver=0.9.46
+pkgrel=5
+pkgdesc='Open Link Layer Discovery Protocol - LLDP Agent Daemon'
+arch=('i686' 'x86_64')
+url='http://www.open-lldp.org/'
+depends=('libnl1' 'libconfig')
+optdepends=('bash-completion: command completion in bash')
+license=('GPL')
+validpgpkeys=('3BD16778540AE9BA587760BB7969EDCB5CFA09CB') # John Fastabend
+source=("http://ftp-osl.osuosl.org/pub/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
+ 'configure.patch'
+ 'makefile.patch')
+sha256sums=('c7b4abc970bf4cc12617b8124de0b440e69fc2a9f680973d2c313301802def14'
+ 'SKIP'
+ '3459d8d8b37c188d3a837fc9fb91d9680294c22f1cf6a27cd66b3b3b89667971'
+ 'fa43952bf89146f6d584a56f593f4268926cbc60a20bb8972e134a1506f8db13')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ patch -Np1 < "${srcdir}/configure.patch"
+ patch -Np1 < "${srcdir}/makefile.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ ./bootstrap.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m0644 lldpad.service "${pkgdir}/usr/lib/systemd/system/lldpad.service"
+
+ rm -rf "${pkgdir}/etc/init.d/"
+}
+
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..27dd2f78938a
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,11 @@
+diff --git a/configure.ac b/configure.ac
+index 119ab58..de7e402 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,5 +1,5 @@
+ AC_INIT([lldpad], [0.9.46], [lldp-devel@open-lldp.org])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
++AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
+
+ m4_pattern_allow([AM_PROG_AR])
+ AM_PROG_AR
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..586028de444f
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+index 893fa45..2ae4f8a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -128,7 +128,7 @@ install-data-local: lldpad.init
+ $(MKDIR_P) $(DESTDIR)/etc/init.d
+ $(INSTALL_SCRIPT) lldpad.init $(DESTDIR)/etc/init.d/lldpad
+
+-BASH_COMPLETION_DIR=/etc/bash_completion.d/
++BASH_COMPLETION_DIR=/usr/share/bash-completion/completions/
+
+ install-data-hook:
+ /sbin/chkconfig --add lldpad || true