summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2023-05-31 01:48:46 +0200
committerFichteFoll2023-05-31 01:48:46 +0200
commitb4dfd343b7ced91ac83f5f18211eeb3a57d94349 (patch)
tree1c28f8bbda693e8916c98178f5e486e872a50c91
parent9d8f6706ae9713c65ae4ad17220674d93a9c3698 (diff)
downloadaur-open-riichi-git.tar.gz
Update for git 'file' protocol changes
Also run `arch-meson` inside the `build` function because it checks the presence of `valac`, which is not the case when `pkgbuild` is checked first, because makedeps are installed afterwards.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2e0012e4f15..c979157c28e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = open-riichi-git
pkgdesc = An open source riichi (Japanese) mahjong client
- pkgver = 0.2.0.3.r44.g9a483f3
+ pkgver = 0.2.1.1.r1.gcf3f6e5
pkgrel = 1
url = https://github.com/FluffyStuff/OpenRiichi
arch = x86_64
@@ -24,4 +24,3 @@ pkgbase = open-riichi-git
sha256sums = 49f93bb7a1cb9b128a0a2137438ee7723cd3e9826b59dfafa5ccee83195961d0
pkgname = open-riichi-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ec824ae38b43..01d379686a07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: FichteFoll <fichtefoll2@googlemail.com>
pkgname=open-riichi-git
-pkgver=0.2.0.3.r44.g9a483f3
+pkgver=0.2.1.1.r1.gcf3f6e5
pkgrel=1
pkgdesc='An open source riichi (Japanese) mahjong client'
arch=('x86_64')
@@ -18,7 +18,6 @@ sha256sums=('SKIP'
pkgver() {
cd OpenRiichi
-
git describe --tags --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
}
@@ -27,13 +26,12 @@ prepare() {
# https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules
git submodule init
git config submodule.Engine.url "${srcdir}/Engine"
- git submodule update
-
- arch-meson build
+ git -c protocol.file.allow=always submodule update
}
build() {
cd OpenRiichi
+ arch-meson build
ninja -C build
}