summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2019-05-13 15:33:51 +0200
committerFichteFoll2019-05-13 15:33:51 +0200
commitaec28640bbf8a197998e1aad1f93b96977409ec4 (patch)
tree47a5ce600a0169e935ca678d607a3e9bc1c9224a
downloadaur-aec28640bbf8a197998e1aad1f93b96977409ec4.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--OpenRiichi.desktop10
-rw-r--r--PKGBUILD40
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbc3010a02e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = open-riichi-git
+ pkgdesc = An open source riichi (Japanese) mahjong client
+ pkgver = 0.1.3.2.r1.g8c5918e
+ pkgrel = 1
+ url = https://github.com/FluffyStuff/OpenRiichi
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = vala
+ depends = gcc
+ depends = libgee
+ depends = glew
+ depends = pango
+ depends = sdl2
+ depends = sdl2_image
+ depends = csfml
+ depends = sfml
+ source = OpenRiichi::git+https://github.com/FluffyStuff/OpenRiichi.git
+ source = Engine::git+https://github.com/FluffyStuff/Engine.git
+ source = OpenRiichi.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = fa43b7e9477b3cba48e9a0f50699a480d0b1c12320c950f9b4465eb1d9b4a742
+
+pkgname = open-riichi-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6eeb691b4c6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+OpenRiichi/
+Engine/
+*.log
+*.pkg.tar.xz
diff --git a/OpenRiichi.desktop b/OpenRiichi.desktop
new file mode 100644
index 000000000000..3ac31d7710aa
--- /dev/null
+++ b/OpenRiichi.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=OpenRiichi
+Comment=Japanese Mahjong
+Categories=Game
+Path=/opt/OpenRiichi
+Exec=/opt/OpenRiichi/OpenRiichi
+Terminal=false
+Icon=/usr/share/pixmaps/OpenRiichi.png
+Type=Application
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08cb4ba1c02d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: FichteFoll <fichtefoll2@googlemail.com>
+
+pkgname=open-riichi-git
+pkgver=0.1.3.2.r1.g8c5918e
+pkgrel=1
+pkgdesc='An open source riichi (Japanese) mahjong client'
+arch=('x86_64')
+url='https://github.com/FluffyStuff/OpenRiichi'
+license=('GPL')
+depends=('gcc' 'libgee' 'glew' 'pango' 'sdl2' 'sdl2_image' 'csfml' 'sfml')
+makedepends=('git' 'vala')
+source=('OpenRiichi::git+https://github.com/FluffyStuff/OpenRiichi.git'
+ 'Engine::git+https://github.com/FluffyStuff/Engine.git'
+ 'OpenRiichi.desktop')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'fa43b7e9477b3cba48e9a0f50699a480d0b1c12320c950f9b4465eb1d9b4a742')
+
+pkgver() {
+ cd OpenRiichi
+
+ git describe --tags --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
+}
+
+build() {
+ cd OpenRiichi
+
+ make release
+}
+
+package() {
+ install -Dm 644 OpenRiichi.desktop -t "${pkgdir}"/usr/share/applications
+ # install -Dm 755 ../OpenRiichi.sh "${pkgdir}"/usr/bin/OpenRiichi
+
+ cd OpenRiichi
+ mkdir -p "${pkgdir}"/opt/OpenRiichi
+ cp -r bin/* "${pkgdir}"/opt/OpenRiichi
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/$pkgname/
+ install -Dm 644 bin/Data/Icon.png "${pkgdir}"/usr/share/pixmaps/OpenRiichi.png
+}