summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-01 18:43:06 +0100
committerMichael Gerber2016-01-01 18:43:06 +0100
commit4d4136286c4d8f60f668408db4debaca2c2eda7c (patch)
tree8cddc68c9b3e07c421e20f1959abd2ddc70ad843
downloadaur-4d4136286c4d8f60f668408db4debaca2c2eda7c.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-authorization-standard.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed873ef611be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 17:43:06 UTC 2016
+pkgbase = open-xchange-authorization-standard
+ pkgdesc = Module implementing the default authorization
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-authorization-standard.install
+ arch = any
+ groups = open-xchange-minimal
+ groups = open-xchange
+ groups = open-xchange-all
+ license = GPLv2
+ depends = open-xchange-core
+ provides = open-xchange-authorization-standard
+ source = https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-authorization-standard_7.8.0-6_all.deb
+ sha256sums = 1d74895ac9dcbae38844292e8aa532913addab1f97cb056d19bf6015eb1f627e
+
+pkgname = open-xchange-authorization-standard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ff194fc94b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-authorization-standard
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Module implementing the default authorization'
+groups=('open-xchange-minimal' 'open-xchange' 'open-xchange-all')
+install='open-xchange-authorization-standard.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-core')
+makedepends=()
+conflicts=()
+provides=('open-xchange-authorization-standard')
+source=('https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-authorization-standard_7.8.0-6_all.deb')
+sha256sums=('1d74895ac9dcbae38844292e8aa532913addab1f97cb056d19bf6015eb1f627e')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-authorization-standard.install b/open-xchange-authorization-standard.install
new file mode 100644
index 000000000000..5a0607f15101
--- /dev/null
+++ b/open-xchange-authorization-standard.install
@@ -0,0 +1,16 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange exists. All good."
+ else
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}