summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 17:24:47 +0100
committerMichael Gerber2016-01-02 17:24:47 +0100
commita5705156553733f86d1d293541ddcaa425d69de9 (patch)
treeaffe1fe356c96d2cdacd26ff7934bf9a162fe74e
downloadaur-a5705156553733f86d1d293541ddcaa425d69de9.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-documents-templates.install14
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ca5ffb9f3ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 16:24:46 UTC 2016
+pkgbase = open-xchange-documents-templates
+ pkgdesc = Contains the documents templates for the office productivity
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-documents-templates.install
+ arch = any
+ license = GPLv2
+ provides = open-xchange-documents-templates
+ source = https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-documents-templates_7.8.0-6_all.deb
+ sha256sums = e1f4989ee5585fcfb0171bde9f93ae01236a5148afc44e03205f19bd92289e9f
+
+pkgname = open-xchange-documents-templates
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..363feb1e274c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-documents-templates
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Contains the documents templates for the office productivity'
+groups=()
+install='open-xchange-documents-templates.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=()
+makedepends=()
+conflicts=()
+provides=('open-xchange-documents-templates')
+source=('https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-documents-templates_7.8.0-6_all.deb')
+sha256sums=('e1f4989ee5585fcfb0171bde9f93ae01236a5148afc44e03205f19bd92289e9f')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-documents-templates.install b/open-xchange-documents-templates.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-documents-templates.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}