summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 17:24:49 +0100
committerMichael Gerber2016-01-02 17:24:49 +0100
commit6a3c3de91090a529442257eae36b3ee6d3dd4250 (patch)
tree36b52c7b612f0d69089e3601f9debbe0a10736c8
downloadaur-6a3c3de91090a529442257eae36b3ee6d3dd4250.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-documents-ui.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8c25ae27ede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 16:24:49 UTC 2016
+pkgbase = open-xchange-documents-ui
+ pkgdesc = Meta package for all Open-Xchange Documents web applications
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-documents-ui.install
+ arch = any
+ license = GPLv2
+ depends = open-xchange-documents-ui-editors
+ provides = open-xchange-documents-ui
+ source = https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-documents-ui_7.8.0-6_all.deb
+ sha256sums = e6065de395625ef1bdb708e30d6d64b791d1dcea4e25391af2152ae3e9e75a61
+
+pkgname = open-xchange-documents-ui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f550baf03e03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-documents-ui
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Meta package for all Open-Xchange Documents web applications'
+groups=()
+install='open-xchange-documents-ui.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-documents-ui-editors')
+makedepends=()
+conflicts=()
+provides=('open-xchange-documents-ui')
+source=('https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-documents-ui_7.8.0-6_all.deb')
+sha256sums=('e6065de395625ef1bdb708e30d6d64b791d1dcea4e25391af2152ae3e9e75a61')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-documents-ui.install b/open-xchange-documents-ui.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-documents-ui.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}