summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 15:55:38 +0100
committerMichael Gerber2016-01-02 15:55:38 +0100
commitb0d9204d746e94b609eac487c158ead50e3f6d34 (patch)
tree1c523d3bf5b71ca529b7327a45051c6afbaab527
downloadaur-open-xchange-drive.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-drive.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d1298a9cb3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 14:55:38 UTC 2016
+pkgbase = open-xchange-drive
+ pkgdesc = Server module for Open-Xchange Drive file synchronization
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-drive.install
+ arch = any
+ license = GPLv2
+ depends = open-xchange-core
+ provides = open-xchange-drive
+ source = https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-drive_7.8.0-6_all.deb
+ sha256sums = fc3b4c3dd8459b3e7f32dc3f4b88ccab9780c21b55de9a63db87fefff7a1c5bd
+
+pkgname = open-xchange-drive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72e28385b6b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-drive
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Server module for Open-Xchange Drive file synchronization'
+groups=()
+install='open-xchange-drive.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-core')
+makedepends=()
+conflicts=()
+provides=('open-xchange-drive')
+source=('https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-drive_7.8.0-6_all.deb')
+sha256sums=('fc3b4c3dd8459b3e7f32dc3f4b88ccab9780c21b55de9a63db87fefff7a1c5bd')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-drive.install b/open-xchange-drive.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-drive.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}