summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-01 18:44:12 +0100
committerMichael Gerber2016-01-01 18:44:12 +0100
commite2757cc4bb75a0f077664f6dc7fc700646ab1593 (patch)
tree2cec0e723457401777920d2355859f90fae988a3
downloadaur-e2757cc4bb75a0f077664f6dc7fc700646ab1593.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-grizzly.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1408dddb9f6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 17:44:12 UTC 2016
+pkgbase = open-xchange-grizzly
+ pkgdesc = The Open-Xchange HTTP Server and Servlet Container
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-grizzly.install
+ arch = any
+ groups = open-xchange-minimal
+ groups = open-xchange
+ groups = open-xchange-all
+ license = GPLv2
+ depends = open-xchange-core
+ provides = open-xchange-grizzly
+ source = https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-grizzly_7.8.0-6_all.deb
+ sha256sums = 575cb322735d658023e9851b755470b34739b559f427df8c8e0ef0816fc5fc28
+
+pkgname = open-xchange-grizzly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9155598623f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-grizzly
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='The Open-Xchange HTTP Server and Servlet Container'
+groups=('open-xchange-minimal' 'open-xchange' 'open-xchange-all')
+install='open-xchange-grizzly.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-core')
+makedepends=()
+conflicts=()
+provides=('open-xchange-grizzly')
+source=('https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-grizzly_7.8.0-6_all.deb')
+sha256sums=('575cb322735d658023e9851b755470b34739b559f427df8c8e0ef0816fc5fc28')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-grizzly.install b/open-xchange-grizzly.install
new file mode 100644
index 000000000000..5a0607f15101
--- /dev/null
+++ b/open-xchange-grizzly.install
@@ -0,0 +1,16 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange exists. All good."
+ else
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}