summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 15:56:11 +0100
committerMichael Gerber2016-01-02 15:56:11 +0100
commitf530f8f2ec24308d01de0cab82679b2db2f861c7 (patch)
tree488a46665c6a8e65b4ea75661d93ab4ea257cdb9
downloadaur-f530f8f2ec24308d01de0cab82679b2db2f861c7.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-osgi.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3772746774f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 14:56:11 UTC 2016
+pkgbase = open-xchange-osgi
+ pkgdesc = 3rd party OSGi bundles used by the Open-Xchange backend
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-osgi.install
+ arch = any
+ groups = open-xchange-minimal
+ license = GPLv2
+ provides = open-xchange-osgi
+ source = https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-osgi_7.8.0-6_all.deb
+ sha256sums = d4b96f5e6b0e194bc3a6c6c3827b12972b801765491d3dd27dcc750f5697ead9
+
+pkgname = open-xchange-osgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6f87d8c0993
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-osgi
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='3rd party OSGi bundles used by the Open-Xchange backend'
+groups=('open-xchange-minimal')
+install='open-xchange-osgi.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=()
+makedepends=()
+conflicts=()
+provides=('open-xchange-osgi')
+source=('https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-osgi_7.8.0-6_all.deb')
+sha256sums=('d4b96f5e6b0e194bc3a6c6c3827b12972b801765491d3dd27dcc750f5697ead9')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-osgi.install b/open-xchange-osgi.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-osgi.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}