summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Kozdrój2020-11-10 19:01:23 +0100
committerRafał Kozdrój2020-11-10 19:01:23 +0100
commitae9dcc9511e1b9585fc9e4b6b5dcdd92e64da807 (patch)
treeff7bec83b7633a0c326126d5c7a669de7e4a153f
parent324105036ad40310eae29e439d8607435c2bd863 (diff)
downloadaur-ae9dcc9511e1b9585fc9e4b6b5dcdd92e64da807.tar.gz
upgpkg: openal-git 1.21.0.r11.g7e767702-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 362f9e8c1a40..3bb131d79b6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openal-git
pkgdesc = Cross-platform 3D audio library, software implementation
- pkgver = 1.18.1.r84.g5ec11a01
+ pkgver = 1.21.0.r11.g7e767702
pkgrel = 1
url = https://github.com/kcat/openal-soft
arch = i686
@@ -13,27 +13,28 @@ pkgbase = openal-git
makedepends = jack
makedepends = qt5-base
makedepends = sdl2
- makedepends = sdl_sound
+ makedepends = libsndfile
makedepends = ffmpeg
+ makedepends = libmysofa
makedepends = git
makedepends = cmake
- makedepends = ninja
- depends = glibc
+ depends = gcc-libs
+ optdepends = qt5-base: alsoft-config GUI Configurator
+ optdepends = fluidsynth: MIDI rendering
+ optdepends = libmysofa: makemhr tool
source = git+https://github.com/kcat/openal-soft
md5sums = SKIP
pkgname = openal-git
- optdepends = qt5-base: alsoft-config GUI Configurator
- optdepends = fluidsynth: MIDI rendering
- provides = openal=1.18.1.r84.g5ec11a01
+ provides = openal=1.21.0.r11.g7e767702
conflicts = openal
pkgname = openal-examples-git
pkgdesc = Cross-platform 3D audio library, software implementation (example programs)
- depends = openal-git=1.18.1.r84.g5ec11a01-1
+ depends = openal-git=1.21.0.r11.g7e767702-1
depends = sdl2
- depends = sdl_sound
+ depends = libsndfile
depends = ffmpeg
- provides = openal-examples=1.18.1.r84.g5ec11a01
+ provides = openal-examples=1.21.0.r11.g7e767702
conflicts = openal-examples
diff --git a/PKGBUILD b/PKGBUILD
index 7bb3c65a21e4..8e197fad78c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,18 @@
pkgbase=openal-git
pkgname=(openal-git openal-examples-git)
-pkgver=1.18.1.r84.g5ec11a01
+pkgver=1.21.0.r11.g7e767702
pkgrel=1
pkgdesc="Cross-platform 3D audio library, software implementation"
arch=(i686 x86_64)
url="https://github.com/kcat/openal-soft"
license=(LGPL)
-depends=(glibc)
-makedepends=(alsa-lib libpulse fluidsynth portaudio jack qt5-base sdl2 sdl_sound ffmpeg
- git cmake ninja)
+depends=(gcc-libs)
+makedepends=(alsa-lib libpulse fluidsynth portaudio jack qt5-base sdl2
+ libsndfile ffmpeg libmysofa git cmake)
+optdepends=('qt5-base: alsoft-config GUI Configurator'
+ 'fluidsynth: MIDI rendering'
+ 'libmysofa: makemhr tool')
source=("git+https://github.com/kcat/openal-soft")
md5sums=('SKIP')
@@ -23,34 +26,35 @@ pkgver() {
}
build() {
- mkdir -p build examples
- cd build
- cmake ../openal-soft -G Ninja \
+ cmake -S openal-soft -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_LIBDIR=lib
- ninja
+ cmake --build build
}
package_openal-git() {
- optdepends=('qt5-base: alsoft-config GUI Configurator'
- 'fluidsynth: MIDI rendering')
provides=("openal=$pkgver")
conflicts=("openal")
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" cmake --install build
install -Dt "$pkgdir/usr/share/doc/openal" -m644 openal-soft/docs/*
### Split openal-examples
- mv -v "$pkgdir"/usr/bin/al{ffplay,hrtf,latency,loopback,record,reverb,stream} examples/
+ mkdir -p examples/usr/bin
+ for f in \
+ alffplay alhrtf allatency alloopback almultireverb alplay alrecord \
+ alreverb alstream altonegen
+ do
+ mv -v "$pkgdir/usr/bin/$f" examples/usr/bin/$f
+ done
}
package_openal-examples-git() {
pkgdesc+=" (example programs)"
- depends=("openal-git=$pkgver-$pkgrel" sdl2 sdl_sound ffmpeg)
+ depends=("openal-git=$pkgver-$pkgrel" sdl2 libsndfile ffmpeg)
provides=("openal-examples=$pkgver")
conflicts=("openal-examples")
- mkdir "$pkgdir/usr"
- mv -v examples "$pkgdir/usr/bin"
+ mv examples/* "$pkgdir"
}