summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-08-27 11:17:02 -0400
committerVincent Grande2020-08-27 11:17:02 -0400
commit699974de7c95fc3909823095d04c05260eb09dd0 (patch)
tree4a24f73b84c0e790751153acd8df0305e231e83f
downloadaur-699974de7c95fc3909823095d04c05260eb09dd0.tar.gz
initial upload
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a25c71ea1cb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = openal-git
+ pkgdesc = Cross-platform 3D audio library, software implementation
+ pkgver = 1.18.1.r84.g5ec11a01
+ pkgrel = 1
+ url = https://github.com/kcat/openal-soft
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = alsa-lib
+ makedepends = libpulse
+ makedepends = sdl2
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ depends = glibc
+ optdepends = qt5-base: alsoft-config GUI Configurator
+ source = git+https://github.com/kcat/openal-soft
+ md5sums = SKIP
+
+pkgname = openal-git
+ optdepends = qt5-base: alsoft-config GUI Configurator
+ optdepends = fluidsynth: MIDI rendering
+ provides = openal=1.18.1.r84.g5ec11a01
+ conflicts = openal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1308798da62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Rafał Kozdrój <kozeid2@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Jason Chu <jchu@xentac.net>
+
+pkgbase=openal-git
+pkgname=(openal-git)
+pkgver=1.18.1.r84.g5ec11a01
+pkgrel=1
+pkgdesc="Cross-platform 3D audio library, software implementation"
+arch=(i686 x86_64)
+url="https://github.com/kcat/openal-soft"
+license=(LGPL)
+depends=(glibc)
+makedepends=(alsa-lib libpulse sdl2
+ git cmake ninja)
+optdepends=('qt5-base: alsoft-config GUI Configurator')
+source=("git+https://github.com/kcat/openal-soft")
+md5sums=('SKIP')
+
+pkgver() {
+ cd openal-soft
+ git describe --long --tags | sed 's/^openal-soft-//;s/-/.r/;s/-/./g'
+}
+
+build() {
+ cd build
+ cmake ../openal-soft -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ ninja
+}
+
+package_openal-git() {
+ optdepends=('qt5-base: alsoft-config GUI Configurator'
+ 'fluidsynth: MIDI rendering')
+ provides=("openal=$pkgver")
+ conflicts=("openal")
+
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dt "$pkgdir/usr/share/doc/openal" -m644 openal-soft/docs/*
+}