summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealitygaps2015-07-06 16:52:26 +0200
committerrealitygaps2015-07-06 16:52:26 +0200
commitb29976330427f04638e280d20244a91bdced5cd6 (patch)
tree6061b32d8d3afda3e2faefcbc11d61f38cf84224
downloadaur-b29976330427f04638e280d20244a91bdced5cd6.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--openatrium.install46
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..237ff5613889
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = openatrium
+ pkgdesc = Open Atrium is an intranet and project management system based on drupal
+ pkgver = 2.12
+ pkgrel = 1
+ url = http://www.openatrium.com/
+ install = openatrium.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = php
+ backup = srv/http/atrium/.htaccess
+ source = http://ftp.drupal.org/files/projects/openatrium-7.x-2.12-core.tar.gz
+ md5sums = 11018e58a824b6531b49cb096e5c5f87
+
+pkgname = openatrium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..347e58b68bf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: realitygaps <realitygaps AT yahoo DOT com>
+
+pkgname=openatrium
+pkgver=2.12
+pkgrel=1
+pkgdesc="Open Atrium is an intranet and project management system based on drupal"
+arch=('i686' 'x86_64')
+url="http://www.openatrium.com/"
+license=('GPL')
+depends=('php')
+install=${pkgname}.install
+backup=(srv/http/atrium/.htaccess)
+source=(http://ftp.drupal.org/files/projects/${pkgname}-7.x-${pkgver}-core.tar.gz)
+md5sums=('11018e58a824b6531b49cb096e5c5f87')
+
+build() {
+ mkdir -p $startdir/pkg/${pkgname}/srv/http/atrium
+ cp -r $startdir/src/$pkgname-7.x-$pkgver/{*,.htaccess} $startdir/pkg/${pkgname}/srv/http/atrium
+ echo "deny from all" > $startdir/pkg/${pkgname}/srv/http/atrium/.htaccess
+}
diff --git a/openatrium.install b/openatrium.install
new file mode 100644
index 000000000000..d4c79daa0055
--- /dev/null
+++ b/openatrium.install
@@ -0,0 +1,46 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "Remember that you need to install either mysql or postgresql for this package"
+ echo "to work. Also make sure to read either INSTALL.mysql.txt (for MySQL) or"
+ echo "INSTALL.pgsql.txt (for PostgreSQL) in /srv/www/atrium/."
+ if [[ ! `grep "^extension=mysql.so" /etc/php/php.ini` ]]
+ then echo "If you use mysql you should enable its module by adding the line:"
+ echo " extension=mysql.so"
+ echo "to your /etc/php/php.ini, otherwise atrium won't work."
+ fi
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*