summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2015-09-10 02:12:09 +0200
committerVirtualTam2015-09-10 02:12:09 +0200
commitcb377bb95b6c5e937220fbd54d7c6479708e0eac (patch)
tree4668230a6d61cde30c58d5fb7fe2fa211bedceb1
downloadaur-cb377bb95b6c5e937220fbd54d7c6479708e0eac.tar.gz
OpenAV-Luppp: initial PKGBUILD
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e84520c45469
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = openav-luppp-git
+ pkgdesc = Luppp is a live performance tool, created by OpenAV productions
+ pkgver = release.1.0.1.8.g43aecd2
+ pkgrel = 1
+ url = http://openavproductions.com/luppp/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = cairo
+ depends = jack2
+ depends = liblo
+ depends = libsamplerate
+ depends = libsndfile
+ depends = ntk-git
+ provides = openav-luppp
+ source = git://github.com/harryhaaren/openAV-Luppp.git
+ sha256sums = SKIP
+
+pkgname = openav-luppp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b33528ee7c0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+pkgname=openav-luppp-git
+pkgver=release.1.0.1.8.g43aecd2
+pkgrel=1
+pkgdesc="Luppp is a live performance tool, created by OpenAV productions"
+arch=('i686' 'x86_64')
+url="http://openavproductions.com/luppp/"
+license=('GPL3')
+depends=('cairo' 'jack2' 'liblo' 'libsamplerate' 'libsndfile' 'ntk-git')
+makedepends=('git')
+provides=('openav-luppp')
+_gitname="openAV-Luppp"
+source=(git://github.com/harryhaaren/${_gitname}.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build(){
+ cd ${_gitname}
+ cmake ./ -DCMAKE_INSTALL_PREFIX="/usr" -DRELEASE_BUILD=1
+ make
+}
+
+package() {
+ cd ${_gitname}
+ make DESTDIR=${pkgdir} install
+}