summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2022-10-31 21:13:21 +0600
committerMubashshir2022-10-31 21:13:21 +0600
commitc00580be954e539e8217c20b66c7dd68c03c7212 (patch)
treea6ba20c82332b4de7b47d7fcf854198774b82861
parent7fad48747b1b202ff8d30cf1d0142b4d53c46f47 (diff)
downloadaur-c00580be954e539e8217c20b66c7dd68c03c7212.tar.gz
misc: Fix FS#76255
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a87b0f1a25..98299e3872df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = openbangla-keyboard
license = GPL3
makedepends = cmake
makedepends = rust
+ makedepends = git
depends = ibus
depends = qt5-base
optdepends = ttf-indic-otf: fonts for Bangla and other Indic scripts
diff --git a/PKGBUILD b/PKGBUILD
index a20ff2198f71..1300f6d1b04c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('x86_64')
url="http://openbangla.github.io"
license=('GPL3')
depends=('ibus' 'qt5-base')
-makedepends=('cmake' 'rust')
+makedepends=('cmake' 'rust' 'git')
optdepends=('ttf-indic-otf: fonts for Bangla and other Indic scripts'
'ttf-freebanglafont: miscellaneous fonts for Bangla script')
install="$pkgname.install"
@@ -31,7 +31,7 @@ prepare() {
cd "$pkgname"
git submodule init
git config submodule."src/engine/riti".url "$srcdir/riti"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {
if [[ -d build ]]; then rm -rf build; fi