summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-08-22 19:26:20 +0600
committerMubashshir2020-08-22 19:26:20 +0600
commit12a4b3771a9209e218213c4936f7ee82c7d261cc (patch)
tree09b5a3569132057a8401ab5b7334bab11841a103
downloadaur-12a4b3771a9209e218213c4936f7ee82c7d261cc.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
-rw-r--r--openbangla-keyboard.install5
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..352a098b7324
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = openbangla-keyboard-git
+ pkgdesc = An OpenSource, Unicode compliant Bengali Input Method
+ pkgver = 1.5.1.r77.ga289143
+ pkgrel = 1
+ url = http://openbangla.github.io
+ install = openbangla-keyboard.install
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = ibus
+ depends = qt5-base
+ optdepends = ttf-indic-otf: fonts for Bangla and other Indic scripts
+ optdepends = ttf-freebanglafont: miscellaneous fonts for Bangla script
+ source = openbangla-keyboard::git+https://github.com/OpenBangla/OpenBangla-Keyboard
+ source = git+https://github.com/OpenBangla/riti
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = openbangla-keyboard-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d396ae6df0d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!openbangla-keyboard.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bd984d29bed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sammay Sarkar <(my-name-without-vowels)@gmail.com>
+pkgname="openbangla-keyboard-git"
+pkgver=1.5.1.r77.ga289143
+pkgrel=1
+pkgdesc="An OpenSource, Unicode compliant Bengali Input Method"
+arch=('x86_64')
+url="http://openbangla.github.io"
+license=('GPL3')
+depends=('ibus' 'qt5-base')
+makedepends=('cmake')
+optdepends=('ttf-indic-otf: fonts for Bangla and other Indic scripts'
+ 'ttf-freebanglafont: miscellaneous fonts for Bangla script')
+install="${pkgname%*-git}.install"
+source=(
+ "${pkgname%*-git}::git+https://github.com/OpenBangla/OpenBangla-Keyboard"
+ "git+https://github.com/OpenBangla/riti"
+)
+sha256sums=('SKIP' 'SKIP')
+pkgver()
+{
+ cd "$srcdir/${pkgname%*-git}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+ pkgrel=$(git diff --shortstat|cut -d' ' -f2)
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%*-git}"
+ git submodule init
+ git config submodule."src/engine/riti".url $srcdir/riti
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/${pkgname%*-git}"
+ if [[ -d build ]]; then rm -rf build; fi
+ mkdir build && cd build
+ cmake ..
+ make
+}
+package() {
+ cd "$srcdir/${pkgname%*-git}"
+ make -C build DESTDIR="$pkgdir" install
+}
diff --git a/openbangla-keyboard.install b/openbangla-keyboard.install
new file mode 100644
index 000000000000..c5ce22cbad37
--- /dev/null
+++ b/openbangla-keyboard.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "To enable OpenBangla-Keyboard:"
+ echo "1. Make sure ibus is the active input method,"
+ echo "2. Add the OpenBangla-Keyboard engine to ibus input method list."
+}