summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-10-11 13:49:46 +0200
committerGianluca Boiano2018-10-11 13:49:46 +0200
commit029be585dd72a9d663cffe622b12a259dd7b43be (patch)
treea17b3264064109a9bc1e6290b3a7bf0c152128aa
parentb1fb0c7be2d0aa88098d49b3c182fb9ecbc2fd18 (diff)
downloadaur-029be585dd72a9d663cffe622b12a259dd7b43be.tar.gz
openbazaar: some fixes for url bar and electron 2
-rw-r--r--.SRCINFO6
-rw-r--r--0bf7d134dc13540b277c10fbd1efb8013aae603e.patch22
-rw-r--r--PKGBUILD16
-rw-r--r--ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch22
4 files changed, 61 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60ab1c3e364c..126cdc40f830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openbazaar
pkgdesc = Front-end Electron application for talking with the OpenBazaar daemon
pkgver = 2.2.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OpenBazaar/openbazaar-desktop
install = openbazaar.install
arch = i686
@@ -13,9 +13,13 @@ pkgbase = openbazaar
source = https://github.com/OpenBazaar/openbazaar-desktop/archive/v2.2.5.tar.gz
source = openbazaar.js
source = openbazaar.desktop
+ source = ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ source = 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
md5sums = 572a60b5a7b89e87b039e4bea67db990
md5sums = 122a3e23d7ecfef0a82e756cb97c3e98
md5sums = 2e7c7804b970baa7f9274dae47618a52
+ md5sums = cc30e1a4742c4e671275842e8b450916
+ md5sums = 72266e0d0f3e3137cbea70f0dade7bfc
pkgname = openbazaar
diff --git a/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch b/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
new file mode 100644
index 000000000000..ed980625b824
--- /dev/null
+++ b/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
@@ -0,0 +1,22 @@
+From 0bf7d134dc13540b277c10fbd1efb8013aae603e Mon Sep 17 00:00:00 2001
+From: Gianluca Boiano <morf3089@gmail.com>
+Date: Thu, 20 Sep 2018 14:37:02 +0200
+Subject: [PATCH] uploadToServer replaces deprecated autoSubmit
+
+---
+ main.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.js b/main.js
+index ddc4d807b..e968920e2 100644
+--- a/main.js
++++ b/main.js
+@@ -142,7 +142,7 @@ crashReporter.start({
+ productName: 'OpenBazaar 2',
+ companyName: 'OpenBazaar',
+ submitURL: 'http://104.131.17.128:1127/post',
+- autoSubmit: true,
++ uploadToServer: true,
+ extra: {
+ bundled: isBundledApp,
+ },
diff --git a/PKGBUILD b/PKGBUILD
index e5879e2122b6..4a405b1a77f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openbazaar
pkgver=2.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon"
arch=(i686 x86_64)
url="https://github.com/OpenBazaar/openbazaar-desktop"
@@ -12,12 +12,19 @@ makedepends=(npm)
source=("https://github.com/OpenBazaar/openbazaar-desktop/archive/v$pkgver.tar.gz"
"$pkgname.js"
"$pkgname.desktop"
+ ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
)
install=$pkgname.install
options=('!strip')
build(){
cd $srcdir/$pkgname-desktop-$pkgver
+
+# Some electron fixes
+ patch -Np1 -i ../ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ patch -Np1 -i ../0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+
npm install --silent
npm run build
npm prune --production
@@ -41,10 +48,11 @@ package(){
-name "bin" -prune -exec rm -r '{}' \; \
-or -name "example" -prune -exec rm -r '{}' \; \
-or -name "examples" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \; \
- -or -executable -type f -exec rm -r '{}' \;
+ -or -name "test" -prune -exec rm -r '{}' \;
}
md5sums=('572a60b5a7b89e87b039e4bea67db990'
'122a3e23d7ecfef0a82e756cb97c3e98'
- '2e7c7804b970baa7f9274dae47618a52')
+ '2e7c7804b970baa7f9274dae47618a52'
+ 'cc30e1a4742c4e671275842e8b450916'
+ '72266e0d0f3e3137cbea70f0dade7bfc')
diff --git a/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch b/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
new file mode 100644
index 000000000000..1e6df06d3d2f
--- /dev/null
+++ b/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
@@ -0,0 +1,22 @@
+From ef26cd0e8014e09b3671500f92c8f1b0d0ebe340 Mon Sep 17 00:00:00 2001
+From: Gianluca Boiano <morf3089@gmail.com>
+Date: Thu, 20 Sep 2018 14:24:39 +0200
+Subject: [PATCH] menu.popup options object should be optional (fix #1560)
+
+---
+ main.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.js b/main.js
+index 6d222a7da..ddc4d807b 100644
+--- a/main.js
++++ b/main.js
+@@ -389,7 +389,7 @@ function createWindow() {
+ Menu.setApplicationMenu(menu);
+
+ ipcMain.on('contextmenu-click', () => {
+- menu.popup();
++ menu.popup({});
+ });
+
+ // put logic here to set tray icon based on OS