summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-12-28 19:30:03 +0100
committerGianluca Boiano2018-12-28 19:30:03 +0100
commiteaf22b4fc1a2f7b7cd0d61f1efdcec19b96996d1 (patch)
treee281a1549512a4a29c06a2af090a54b50f8b1707
parentd93ddda08ae035ccc570f713f782219fe885caa9 (diff)
downloadaur-eaf22b4fc1a2f7b7cd0d61f1efdcec19b96996d1.tar.gz
openbazaar: electron2 as runtime dep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD68
-rwxr-xr-xopenbazaar.js4
3 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 126cdc40f830..fec4793e42aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = openbazaar
arch = x86_64
license = MIT
makedepends = npm
- depends = electron
+ depends = electron2
options = !strip
source = https://github.com/OpenBazaar/openbazaar-desktop/archive/v2.2.5.tar.gz
source = openbazaar.js
@@ -16,7 +16,7 @@ pkgbase = openbazaar
source = ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
source = 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
md5sums = 572a60b5a7b89e87b039e4bea67db990
- md5sums = 122a3e23d7ecfef0a82e756cb97c3e98
+ md5sums = a6f53663934868281cc8aa88c894ed3c
md5sums = 2e7c7804b970baa7f9274dae47618a52
md5sums = cc30e1a4742c4e671275842e8b450916
md5sums = 72266e0d0f3e3137cbea70f0dade7bfc
diff --git a/PKGBUILD b/PKGBUILD
index ddf163e5dd9f..59913f142025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,52 +7,52 @@ pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon"
arch=(i686 x86_64)
url="https://github.com/OpenBazaar/openbazaar-desktop"
license=('MIT')
-depends=(electron)
-makedepends=(npm)
+depends=('electron2')
+makedepends=('npm')
source=("https://github.com/OpenBazaar/openbazaar-desktop/archive/v$pkgver.tar.gz"
- "$pkgname.js"
- "$pkgname.desktop"
- ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
- 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+ "$pkgname.js"
+ "$pkgname.desktop"
+ ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
)
install=$pkgname.install
options=('!strip')
build(){
- cd $srcdir/$pkgname-desktop-$pkgver
+ cd $srcdir/$pkgname-desktop-$pkgver
- # Some electron fixes
- patch -Np1 -i ../ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
- patch -Np1 -i ../0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+ # Some electron fixes
+ patch -Np1 -i ../ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ patch -Np1 -i ../0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
- npm install --silent
- npm run build
- npm prune --production
+ npm install --silent
+ npm run build
+ npm prune --production
}
package(){
- cd $srcdir
- appdir="usr/lib/$pkgname"
-
- install -d $pkgdir/${appdir%%/$pkgname}
- cp -rf $pkgname-desktop-$pkgver $pkgdir/$appdir
- install -Dm755 $pkgname.js $pkgdir/usr/bin/$pkgname
- install -Dm644 $pkgname-desktop-$pkgver/imgs/icon.png $pkgdir/usr/share/pixmaps/${pkgname}2.png
- install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
-
- cd $pkgdir/$appdir
- rm -rf .git*
- rm -rf .travis
- cp -rf prod/* js/
- find "${pkgdir}"/${appdir} \
- -name "bin" -prune -exec rm -r '{}' \; \
- -or -name "example" -prune -exec rm -r '{}' \; \
- -or -name "examples" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \;
+ cd $srcdir
+ appdir="usr/lib/$pkgname"
+
+ install -d $pkgdir/${appdir%%/$pkgname}
+ cp -rf $pkgname-desktop-$pkgver $pkgdir/$appdir
+ install -Dm755 $pkgname.js $pkgdir/usr/bin/$pkgname
+ install -Dm644 $pkgname-desktop-$pkgver/imgs/icon.png $pkgdir/usr/share/pixmaps/${pkgname}2.png
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ cd $pkgdir/$appdir
+ rm -rf .git*
+ rm -rf .travis
+ cp -rf prod/* js/
+ find "${pkgdir}"/${appdir} \
+ -name "bin" -prune -exec rm -r '{}' \; \
+ -or -name "example" -prune -exec rm -r '{}' \; \
+ -or -name "examples" -prune -exec rm -r '{}' \; \
+ -or -name "test" -prune -exec rm -r '{}' \;
}
md5sums=('572a60b5a7b89e87b039e4bea67db990'
- '122a3e23d7ecfef0a82e756cb97c3e98'
- '2e7c7804b970baa7f9274dae47618a52'
- 'cc30e1a4742c4e671275842e8b450916'
+ 'a6f53663934868281cc8aa88c894ed3c'
+ '2e7c7804b970baa7f9274dae47618a52'
+ 'cc30e1a4742c4e671275842e8b450916'
'72266e0d0f3e3137cbea70f0dade7bfc')
diff --git a/openbazaar.js b/openbazaar.js
index 1d7a2c55b571..2ea85fa584ff 100755
--- a/openbazaar.js
+++ b/openbazaar.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron
+#!/usr/bin/electron2
const name = 'openbazaar';
@@ -11,7 +11,7 @@ const fd = fs.openSync('/proc/self/comm', fs.constants.O_WRONLY);
fs.writeSync(fd, name);
fs.closeSync(fd);
-// Remove first command line argument (/usr/bin/electron).
+// Remove first command line argument (/usr/bin/electron2).
process.argv.splice(0, 1);
// Set application paths.