summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-12-25 13:01:23 +0100
committerGianluca Boiano2018-12-25 13:01:23 +0100
commit13869a3cb4f2e61654d756a3e41ddfecf6bcf369 (patch)
treed4830ead3b373b3c930e6edf4c0657a58d13266c
parent3a48cfc78ef37e4b96d4f1d48f31e0c82f87d503 (diff)
downloadaur-13869a3cb4f2e61654d756a3e41ddfecf6bcf369.tar.gz
openbazaar-git: updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rwxr-xr-xopenbazaar.js4
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 121d21fbfd36..569385e22189 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openbazaar-git
pkgdesc = Front-end Electron application for talking with the OpenBazaar daemon (Latest devel version)
- pkgver = v2.2.5.r23.g2f786923
+ pkgver = v2.3.0.rc3.r0.ga478dcda
pkgrel = 1
url = https://github.com/OpenBazaar/openbazaar-desktop
install = openbazaar.install
@@ -8,14 +8,14 @@ pkgbase = openbazaar-git
license = MIT
makedepends = git
makedepends = npm
- depends = electron
+ depends = electron2
conflicts = openbazaar
options = !strip
source = openbazaar::git+https://github.com/OpenBazaar/openbazaar-desktop.git
source = openbazaar.js
source = openbazaar.desktop
md5sums = SKIP
- md5sums = 446ad1e41acd07468c3750a9027dc8f8
+ md5sums = 6d2e87f99126f791e2ebd770c4b147de
md5sums = a278f17aa965510cadb534df49b245dd
pkgname = openbazaar-git
diff --git a/PKGBUILD b/PKGBUILD
index 6285ead7a76a..4b69433df6b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: robertfoster
pkgname=openbazaar-git
-pkgver=v2.2.5.r23.g2f786923
+pkgver=v2.3.0.rc3.r0.ga478dcda
pkgrel=1
pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon (Latest devel version)"
arch=(any)
url="https://github.com/OpenBazaar/openbazaar-desktop"
license=('MIT')
-depends=(electron)
-makedepends=(git npm)
+depends=('electron2')
+makedepends=('git' 'npm')
conflicts=('openbazaar')
source=("${pkgname%%-git}::git+https://github.com/OpenBazaar/openbazaar-desktop.git"
"${pkgname%%-git}.js"
@@ -22,7 +22,6 @@ build(){
npm install --silent
npm run build
- npm prune --production
}
package(){
@@ -58,5 +57,5 @@ pkgver() {
}
md5sums=('SKIP'
- '446ad1e41acd07468c3750a9027dc8f8'
+ '6d2e87f99126f791e2ebd770c4b147de'
'a278f17aa965510cadb534df49b245dd')
diff --git a/openbazaar.js b/openbazaar.js
index 41ca7f18cb5a..b9b1c2aa5bd8 100755
--- a/openbazaar.js
+++ b/openbazaar.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron
+#!/usr/bin/electron2
const name = 'openbazaar';
@@ -11,7 +11,7 @@ const fd = fs.openSync('/proc/self/comm', fs.constants.O_WRONLY);
fs.writeSync(fd, name);
fs.closeSync(fd);
-// Remove first command line argument (/usr/bin/electron).
+// Remove first command line argument (/usr/bin/electron2).
process.argv.splice(0, 1);
// Set development mode