summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-10-11 13:53:30 +0200
committerGianluca Boiano2018-10-11 13:53:30 +0200
commit2a000d11751fbea6295223cebc6a74745d2805ee (patch)
treed980a8e9c9298fb454aa3db367aa22b0d4d18bb8
parent3e4f04ad1003fe9525ed6b2d1cac76a891c7e19a (diff)
downloadaur-2a000d11751fbea6295223cebc6a74745d2805ee.tar.gz
openbazaar-git: updated
-rw-r--r--.SRCINFO6
-rw-r--r--0bf7d134dc13540b277c10fbd1efb8013aae603e.patch22
-rw-r--r--PKGBUILD17
-rw-r--r--ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch22
4 files changed, 62 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e59a15cf52..b6e87c8274f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openbazaar-git
pkgdesc = Front-end Electron application for talking with the OpenBazaar daemon (Latest devel version)
- pkgver = v2.2.2.rc1.r0.g137cb661
+ pkgver = v2.2.5.r12.gd08100dd
pkgrel = 1
url = https://github.com/OpenBazaar/openbazaar-desktop
install = openbazaar.install
@@ -14,9 +14,13 @@ pkgbase = openbazaar-git
source = openbazaar::git+https://github.com/OpenBazaar/openbazaar-desktop.git
source = openbazaar.js
source = openbazaar.desktop
+ source = ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ source = 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
md5sums = SKIP
md5sums = 446ad1e41acd07468c3750a9027dc8f8
md5sums = a278f17aa965510cadb534df49b245dd
+ md5sums = cc30e1a4742c4e671275842e8b450916
+ md5sums = 72266e0d0f3e3137cbea70f0dade7bfc
pkgname = openbazaar-git
diff --git a/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch b/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
new file mode 100644
index 000000000000..ed980625b824
--- /dev/null
+++ b/0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
@@ -0,0 +1,22 @@
+From 0bf7d134dc13540b277c10fbd1efb8013aae603e Mon Sep 17 00:00:00 2001
+From: Gianluca Boiano <morf3089@gmail.com>
+Date: Thu, 20 Sep 2018 14:37:02 +0200
+Subject: [PATCH] uploadToServer replaces deprecated autoSubmit
+
+---
+ main.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.js b/main.js
+index ddc4d807b..e968920e2 100644
+--- a/main.js
++++ b/main.js
+@@ -142,7 +142,7 @@ crashReporter.start({
+ productName: 'OpenBazaar 2',
+ companyName: 'OpenBazaar',
+ submitURL: 'http://104.131.17.128:1127/post',
+- autoSubmit: true,
++ uploadToServer: true,
+ extra: {
+ bundled: isBundledApp,
+ },
diff --git a/PKGBUILD b/PKGBUILD
index 6df52f7f5fd4..12543d31362a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=openbazaar-git
-pkgver=v2.2.2.rc1.r0.g137cb661
+pkgver=v2.2.5.r12.gd08100dd
pkgrel=1
pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon (Latest devel version)"
arch=(any)
@@ -13,12 +13,20 @@ conflicts=('openbazaar')
source=("${pkgname%%-git}::git+https://github.com/OpenBazaar/openbazaar-desktop.git"
"${pkgname%%-git}.js"
"${pkgname%%-git}.desktop"
+ ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ 0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+
)
install=${pkgname%%-git}.install
options=('!strip')
build(){
cd $srcdir/${pkgname%%-git}
+
+ # Some electron fixes
+ patch -Np1 -i ../ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
+ patch -Np1 -i ../0bf7d134dc13540b277c10fbd1efb8013aae603e.patch
+
npm install --silent
npm run build
npm prune --production
@@ -48,8 +56,7 @@ package(){
-name "bin" -prune -exec rm -r '{}' \; \
-or -name "example" -prune -exec rm -r '{}' \; \
-or -name "examples" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \; \
- -or -executable -type f -exec rm -r '{}' \;
+ -or -name "test" -prune -exec rm -r '{}' \;
}
pkgver() {
@@ -59,4 +66,6 @@ pkgver() {
md5sums=('SKIP'
'446ad1e41acd07468c3750a9027dc8f8'
-'a278f17aa965510cadb534df49b245dd')
+ 'a278f17aa965510cadb534df49b245dd'
+ 'cc30e1a4742c4e671275842e8b450916'
+'72266e0d0f3e3137cbea70f0dade7bfc')
diff --git a/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch b/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
new file mode 100644
index 000000000000..1e6df06d3d2f
--- /dev/null
+++ b/ef26cd0e8014e09b3671500f92c8f1b0d0ebe340.patch
@@ -0,0 +1,22 @@
+From ef26cd0e8014e09b3671500f92c8f1b0d0ebe340 Mon Sep 17 00:00:00 2001
+From: Gianluca Boiano <morf3089@gmail.com>
+Date: Thu, 20 Sep 2018 14:24:39 +0200
+Subject: [PATCH] menu.popup options object should be optional (fix #1560)
+
+---
+ main.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.js b/main.js
+index 6d222a7da..ddc4d807b 100644
+--- a/main.js
++++ b/main.js
+@@ -389,7 +389,7 @@ function createWindow() {
+ Menu.setApplicationMenu(menu);
+
+ ipcMain.on('contextmenu-click', () => {
+- menu.popup();
++ menu.popup({});
+ });
+
+ // put logic here to set tray icon based on OS