summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-11-26 08:40:10 -0500
committerGuillaume Horel2019-11-26 08:42:31 -0500
commit0434ec1929931b4614380b39b0e872840676ef5f (patch)
tree888297b3462502e35161962db5f8158dcf2283f5
parent975d7dd2f37bfe646ab8fa30a953a643dce3c655 (diff)
downloadaur-0434ec1929931b4614380b39b0e872840676ef5f.tar.gz
version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc232e04c50..f4835869d464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
- pkgver = 0.3.6
+ pkgver = 0.3.7
pkgrel = 2
url = http://www.openblas.net/
arch = x86_64
@@ -19,8 +19,8 @@ pkgbase = openblas-lapack
conflicts = cblas
conflicts = lapacke
options = !emptydirs
- source = OpenBLAS-0.3.6.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.6.tar.gz
- sha256sums = e64c8fe083832ffbc1459ab6c72f71d53afd3b36e8497c922a15a06b72e9002f
+ source = OpenBLAS-0.3.7.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.7.tar.gz
+ sha256sums = bde136122cef3dd6efe2de1c6f65c10955bbb0cc01a520c2342f5287c28f9379
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index 16b5e2f54c15..12b5fb2b13b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
+# Maintainer: thrasibule <guillaume.horel@gmail.com>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
# Contributor: Jiaxi Hu <sftrytry _AT_ gmail _DOT_ com>
# Contributor: Giuseppe Borzi <gborzi _AT_ ieee _DOT_ org>
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.6
+pkgver=0.3.7
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.8.0
pkgrel=2
@@ -19,13 +20,13 @@ provides=('openblas' "blas=${_lapackver}" "lapack=${_lapackver}" "cblas=${_lapac
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('e64c8fe083832ffbc1459ab6c72f71d53afd3b36e8497c922a15a06b72e9002f')
+sha256sums=('bde136122cef3dd6efe2de1c6f65c10955bbb0cc01a520c2342f5287c28f9379')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
-_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 \
- NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1 \
- MAJOR_VERSION=${_lapackver:0:1} NO_STATIC=1"
+_config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
+ USE_TLS=1 \
+ NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1"
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"