summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-01-02 21:49:34 -0500
committerGuillaume Horel2022-01-02 21:49:34 -0500
commit9a12f169a4c69d76e9c3a032d4069cc17910bfa3 (patch)
treef4a9fccea3940a92f95b10750acabd187ac3a849
parent52f51eefeaec57aded0b84b144a04de6b4ae5026 (diff)
downloadaur-9a12f169a4c69d76e9c3a032d4069cc17910bfa3.tar.gz
backport bugfix from upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f5c2542ca06..f69b0e573225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.3.19
- pkgrel = 1
+ pkgrel = 2
url = http://www.openblas.net/
arch = x86_64
license = BSD
@@ -20,6 +20,8 @@ pkgbase = openblas-lapack
conflicts = lapacke
options = !emptydirs
source = OpenBLAS-0.3.19.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.19.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/3504.patch
sha256sums = 947f51bfe50c2a0749304fbe373e00e7637600b0a47b78a51382aeb30ca08562
+ sha256sums = 52a0ce2e8c7e3904cd1f2e65ab877d9370a6fcd23a1cd35e2e6a7ffa9fb4434c
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index 8e5d53c86672..c5a3f48a9a40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=0.3.19
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.9.0
_blasver=3.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -20,8 +20,10 @@ makedepends=('perl' 'gcc-fortran')
provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver}" "lapacke=${_lapackver}")
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
-source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('947f51bfe50c2a0749304fbe373e00e7637600b0a47b78a51382aeb30ca08562')
+source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/3504.patch)
+sha256sums=('947f51bfe50c2a0749304fbe373e00e7637600b0a47b78a51382aeb30ca08562'
+ '52a0ce2e8c7e3904cd1f2e65ab877d9370a6fcd23a1cd35e2e6a7ffa9fb4434c')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
@@ -30,6 +32,11 @@ _config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1 \
MAJOR_VERSION=${_lapackver:0:1} NO_STATIC=1"
+prepare(){
+ cd "${_PkgName}-${pkgver}"
+ patch -p1 -i ../3504.patch
+}
+
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"