summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-03-16 10:28:05 +0100
committereolianoe2016-03-16 10:28:05 +0100
commit322ee8dbf61f0755db3a426efc22eea76e680443 (patch)
tree7440867724d81bca02367c33f28b602f9cae5fe8
parentfa9fc57cecebd9470949b5124449a04200393a40 (diff)
downloadaur-322ee8dbf61f0755db3a426efc22eea76e680443.tar.gz
Upstream release: 0.2.16
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abd0539ade49..d3a5affdec92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Feb 7 10:49:27 UTC 2016
+# Wed Mar 16 09:27:51 UTC 2016
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
- pkgver = 0.2.15
- pkgrel = 4
+ pkgver = 0.2.16
+ pkgrel = 1
url = http://xianyi.github.com/OpenBLAS/
arch = i686
arch = x86_64
@@ -12,18 +12,18 @@ pkgbase = openblas-lapack
makedepends = gcc-fortran
depends = gcc-libs
provides = openblas
- provides = blas=3.5.0
- provides = lapack=3.5.0
- provides = cblas=3.5.0
- provides = lapacke=3.5.0
+ provides = blas=3.6.0
+ provides = lapack=3.6.0
+ provides = cblas=3.6.0
+ provides = lapacke=3.6.0
conflicts = openblas
conflicts = blas
conflicts = lapack
conflicts = cblas
conflicts = lapacke
options = !emptydirs
- source = OpenBLAS-0.2.15.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.2.15.tar.gz
- sha256sums = 73c40ace5978282224e5e122a41c8388c5a19e65a6f2329c2b7c0b61bacc9044
+ source = OpenBLAS-0.2.16.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.2.16.tar.gz
+ sha256sums = 766f350d0a4be614812d535cead8c816fc3ad3b9afcd93167ea5e4df9d61869b
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index de02ecba925c..3113071a274a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.2.15
-_lapackver=3.5.0
-pkgrel=4
+pkgver=0.2.16
+_lapackver=3.6.0
+pkgrel=1
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('i686' 'x86_64')
url="http://xianyi.github.com/OpenBLAS/"
@@ -18,9 +18,12 @@ provides=('openblas' "blas=${_lapackver}" "lapack=${_lapackver}" "cblas=${_lapac
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('73c40ace5978282224e5e122a41c8388c5a19e65a6f2329c2b7c0b61bacc9044')
+sha256sums=('766f350d0a4be614812d535cead8c816fc3ad3b9afcd93167ea5e4df9d61869b')
-_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 MAJOR_VERSION=3 NO_LAPACK=0"
+# Add the following line to the _config variable if you want to set the number of make jobs
+# MAKE_NB_JOBS=2 \
+_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 \
+ MAJOR_VERSION=3 NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1"
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"