summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-06-10 11:05:25 +0200
committereolianoe2015-06-10 11:05:25 +0200
commit758ae09af44f402f8bca723ec0f86a6e85939e89 (patch)
treebfb152e3aeb3c538ab6dccea7adb641dc9c5ed85
parent96c502a9ffffb2cc7ca834024e91aa1405b34459 (diff)
downloadaur-758ae09af44f402f8bca723ec0f86a6e85939e89.tar.gz
Add `FC` to the `_config` variable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ccc71ecd713..bb5b3dd8544c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.2.14
- pkgrel = 3
+ pkgrel = 4
url = http://xianyi.github.com/OpenBLAS/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4626ae594d73..b928d7836a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openblas-lapack
_pkgname=OpenBLAS
pkgver=0.2.14
-pkgrel=3
+pkgrel=4
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('i686' 'x86_64')
url="http://xianyi.github.com/OpenBLAS/"
@@ -18,7 +18,7 @@ options=(!emptydirs)
source=(${_pkgname}-v${pkgver}.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v${pkgver}.tar.gz)
sha256sums=('2411c4f56f477b42dff54db2b7ffc0b7cf53bb9778d54982595c64cc69c40fc1')
-_config="USE_OPENMP=0 USE_THREAD=1 MAJOR_VERSION=3 NO_LAPACK=0"
+_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 MAJOR_VERSION=3 NO_LAPACK=0"
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -27,7 +27,7 @@ build() {
NCORE4PROC=`grep "cores" /proc/cpuinfo|sort|tail -n 1|sed -e 's/cpu cores.*: //'`
let NCORE=NPROC*NCORE4PROC
- make ${_config} NUM_THREADS=$NCORE libs netlib shared
+ make ${_config} NUM_THREADS=${NCORE} libs netlib shared
}
check() {