summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2018-12-08 22:57:05 +0000
committerAndrew Anderson2018-12-08 22:57:05 +0000
commitff533c53f8edf7e9ad906755ed3296af1c5ec9b0 (patch)
tree709184fdecb8e21f8ff78fd440483a479b3b8373
parentf99903bf349c7c29faca1474dffcac11f0d5cdae (diff)
downloadaur-ff533c53f8edf7e9ad906755ed3296af1c5ec9b0.tar.gz
Switch to OpenMP backend
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60f44670e480..de592411caee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack-openmp
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.openblas.net/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 1969c62d21dc..7ca71e075a98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _pkgname=openblas
pkgver=0.3.3
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('any')
url="http://www.openblas.net/"
@@ -24,14 +24,15 @@ sha256sums=('49d88f4494ae780e3d7fa51769c00d982d7cdb73e696054ac3baa81d42f13bab')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
-_config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 \
+
+_config="FC=gfortran USE_OPENMP=1 USE_THREAD=0 \
USE_COMPILER_TLS=0 \
NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1"
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"
- make ${_config} USE_OPENMP=1 libs netlib shared
+ make ${_config} libs netlib shared
}
check(){