summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2020-05-20 15:44:38 +0200
committerMichał Walenciak2020-05-20 15:44:38 +0200
commit1a38b694427b6300d3fe8b7c5ccd2c8d14530a6d (patch)
treec22424315e010671d5ba50db794c8aec8e81531e
parent43658f18bbeb0e1233065b3c52702ed97fd223da (diff)
downloadaur-1a38b694427b6300d3fe8b7c5ccd2c8d14530a6d.tar.gz
use gcc8, sources do not compile with gcc-10 nor clang
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93d2cdcfb083..1dbad82c38de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = openblok
pkgdesc = A customizable, cross platform, open-source falling block game, packed with a bunch of features.
pkgver = 0.8.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mmatyas/openblok
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = gcc8
depends = sdl2
depends = sdl2_image
depends = sdl2_mixer
diff --git a/PKGBUILD b/PKGBUILD
index 84acd07f3a1c..a08dc62d0964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=openblok
pkgver=0.8.2
-pkgrel=2
+pkgrel=3
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
@@ -11,7 +11,7 @@ depends=('sdl2'
'sdl2_image'
'sdl2_mixer'
'sdl2_ttf')
-makedepends=('cmake')
+makedepends=('cmake' 'gcc8')
optdepends=()
provides=()
conflicts=()
@@ -36,7 +36,7 @@ build()
cd $pkgname-$pkgver
mkdir -p build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin -DCMAKE_CXX_COMPILER=c++-8 -DCMAKE_C_COMPILER=gcc-8 ..
make
}