summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2019-03-09 14:28:58 +0100
committerMichał Walenciak2019-03-09 14:28:58 +0100
commit7cab778dac4c8d1fdb686b2fb342a6984160c60b (patch)
tree672faa9eb828ec071677571ee2432b4ab9486eff
parent58cc0321c322658b63a40bdf5b16bd62bb19e9b4 (diff)
downloadaur-7cab778dac4c8d1fdb686b2fb342a6984160c60b.tar.gz
applying patch which fixes data location
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fixed-AppImage-data-path.patch38
-rw-r--r--PKGBUILD8
3 files changed, 46 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 608f98bf2894..779235dca398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = openblok
pkgdesc = A customizable, cross platform, open-source falling block game, packed with a bunch of features.
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mmatyas/openblok
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
source = https://codeload.github.com/mmatyas/openblok/tar.gz/v0.7.0
+ source = 0001-Fixed-AppImage-data-path.patch
md5sums = 0c82fadc6573e4fa0fe84171d169d978
+ md5sums = 47cb3991c7997149f9229230969342ee
pkgname = openblok
diff --git a/0001-Fixed-AppImage-data-path.patch b/0001-Fixed-AppImage-data-path.patch
new file mode 100644
index 000000000000..2a8e76706959
--- /dev/null
+++ b/0001-Fixed-AppImage-data-path.patch
@@ -0,0 +1,38 @@
+From 8760fadf1a29bb078952b6c334dcb74bb5d066a1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C3=A1ty=C3=A1s=20Mustoha?= <matyas.mustoha@gmail.com>
+Date: Mon, 27 Feb 2017 21:11:13 +0100
+Subject: [PATCH] Fixed AppImage data path
+
+---
+ src/CMakeLists.txt | 2 --
+ src/system/CMakeLists.txt | 1 +
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index f07833e..5823868 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -5,8 +5,6 @@ include_directories(openblok PRIVATE "${CMAKE_CURRENT_BINARY_DIR}/generated")
+
+ add_executable(openblok main.cpp version.h)
+
+-target_compile_definitions(openblok PRIVATE OPENBLOK_DATADIR="${DATADIR}")
+-
+ add_subdirectory(system)
+ add_subdirectory(game)
+ target_link_libraries(openblok module_game)
+diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
+index 32274d7..9cc655e 100644
+--- a/src/system/CMakeLists.txt
++++ b/src/system/CMakeLists.txt
+@@ -50,6 +50,7 @@ add_library(module_system ${MOD_SYSTEM_SRC} ${MOD_SYSTEM_H})
+
+ # use SDL2
+ target_include_directories(module_system PRIVATE ${SDL2PP_INCLUDE_DIRS})
++target_compile_definitions(module_system PRIVATE OPENBLOK_DATADIR="${DATADIR}")
+ target_link_libraries(module_system ${SDL2PP_LIBRARIES})
+
+ option(ENABLE_JPG "Enable JPG image support" ON)
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 5c211760f7c7..45cd13f38882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=openblok
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
@@ -17,13 +17,15 @@ backup=()
options=()
install=
changelog=
-source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver)
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver 0001-Fixed-AppImage-data-path.patch)
noextract=()
-md5sums=('0c82fadc6573e4fa0fe84171d169d978')
+md5sums=('0c82fadc6573e4fa0fe84171d169d978'
+ '47cb3991c7997149f9229230969342ee')
build()
{
cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/0001-Fixed-AppImage-data-path.patch"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin