summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2020-01-19 19:00:40 +0100
committerbartus2020-10-11 14:49:24 +0200
commit0e72853d7c1753d539f325943ce045d740aac323 (patch)
tree6d42bd035dec07e5f91239d56a2c3d5c5ff874b3
parent7eeab31379655e3c17ad2d32b3241d7ca1db9d57 (diff)
downloadaur-0e72853d7c1753d539f325943ce045d740aac323.tar.gz
Update to 1.5.3-4: Fix compilation issue
Thanks to loqs at https://bbs.archlinux.org/viewtopic.php?pid=1883212
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--poppler.patch43
3 files changed, 42 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b75d6ebcabad..128463100486 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openboard-develop
pkgdesc = Interactive whiteboard software for schools and universities
pkgver = 1.5.3
- pkgrel = 3
+ pkgrel = 4
url = http://openboard.ch/index.en.html
install = openboard.install
arch = x86_64
@@ -38,7 +38,7 @@ pkgbase = openboard-develop
md5sums = 04c421c140e983d41975943ede5fe61a
md5sums = 21d1749400802f8fc0669feaf77de683
md5sums = 30a7928f696f958d5e8f06e02c49639f
- md5sums = 8b774d204501bb8515ee224651a7d624
+ md5sums = 9a8f9ec3b244390b4c17a10494a94d29
md5sums = 879116c683374b2dde291014e44a29fe
pkgname = openboard-develop
diff --git a/PKGBUILD b/PKGBUILD
index b4cd27b47c69..b56fb597bd7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
# Contributor: bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=openboard-develop
-pkgname=openboard
pkgver=1.5.3
-pkgrel=3
+pkgrel=4
pkgdesc="Interactive whiteboard software for schools and universities"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
@@ -28,7 +27,7 @@ md5sums=('fe3644033dccfd16c80b683210e4ac57'
'04c421c140e983d41975943ede5fe61a'
'21d1749400802f8fc0669feaf77de683'
'30a7928f696f958d5e8f06e02c49639f'
- '8b774d204501bb8515ee224651a7d624'
+ '9a8f9ec3b244390b4c17a10494a94d29'
'879116c683374b2dde291014e44a29fe')
prepare() {
diff --git a/poppler.patch b/poppler.patch
index 50c62230e093..19f7b709ea29 100644
--- a/poppler.patch
+++ b/poppler.patch
@@ -1,5 +1,17 @@
+diff --git a/OpenBoard.pro b/OpenBoard.pro
+index b8a7ae5..0dcf3b8 100644
+--- a/OpenBoard.pro
++++ b/OpenBoard.pro
+@@ -3,6 +3,7 @@ TEMPLATE = app
+
+ THIRD_PARTY_PATH=../OpenBoard-ThirdParty
+
++CONFIG += c++14
+ CONFIG -= flat
+ CONFIG += debug_and_release \
+ no_include_pwd
diff --git a/src/pdf/XPDFRenderer.cpp b/src/pdf/XPDFRenderer.cpp
-index a3e828e4..583882aa 100644
+index a3e828e..a77ee49 100644
--- a/src/pdf/XPDFRenderer.cpp
+++ b/src/pdf/XPDFRenderer.cpp
@@ -32,6 +32,7 @@
@@ -10,7 +22,15 @@ index a3e828e4..583882aa 100644
#include "core/memcheck.h"
-@@ -51,7 +52,7 @@ XPDFRenderer::XPDFRenderer(const QString &filename, bool importingFile)
+@@ -47,11 +48,15 @@ XPDFRenderer::XPDFRenderer(const QString &filename, bool importingFile)
+ {
+ // globalParams must be allocated once and never be deleted
+ // note that this is *not* an instance variable of this XPDFRenderer class
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
++ globalParams = std::make_unique<GlobalParams>();
++#else
+ globalParams = new GlobalParams(0);
++#endif
globalParams->setupBaseFonts(QFile::encodeName(UBPlatformUtils::applicationResourcesDirectory() + "/" + "fonts").data());
}
@@ -19,7 +39,20 @@ index a3e828e4..583882aa 100644
sInstancesCount.ref();
}
-@@ -99,16 +100,28 @@ QString XPDFRenderer::title() const
+@@ -70,8 +75,12 @@ XPDFRenderer::~XPDFRenderer()
+
+ if (sInstancesCount.loadAcquire() == 0 && globalParams)
+ {
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
++ globalParams.reset();
++#else
+ delete globalParams;
+ globalParams = 0;
++#endif
+ }
+ }
+
+@@ -99,16 +108,28 @@ QString XPDFRenderer::title() const
{
if (isValid())
{
@@ -52,7 +85,7 @@ index a3e828e4..583882aa 100644
}
}
}
-@@ -172,12 +185,12 @@ QImage* XPDFRenderer::createPDFImage(int pageNumber, qreal xscale, qreal yscale,
+@@ -172,12 +193,12 @@ QImage* XPDFRenderer::createPDFImage(int pageNumber, qreal xscale, qreal yscale,
SplashColor paperColor = {0xFF, 0xFF, 0xFF}; // white
if(mSplash)
delete mSplash;
@@ -71,7 +104,7 @@ index a3e828e4..583882aa 100644
mSliceY = 0.;
diff --git a/src/pdf/XPDFRenderer.h b/src/pdf/XPDFRenderer.h
-index 8ab200bc..003a2055 100644
+index 8ab200b..003a205 100644
--- a/src/pdf/XPDFRenderer.h
+++ b/src/pdf/XPDFRenderer.h
@@ -36,10 +36,10 @@