summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2018-04-04 11:03:05 +0200
committerbartus2020-10-11 14:46:46 +0200
commita228fbbea868feb0dbdc7100059b3370446da30f (patch)
tree36e6ca080849000df9f6e2ba31930cc3e7aba255
parent0b158cddcb6d77fcb2486ee5a8ffc67f0408544e (diff)
downloadaur-a228fbbea868feb0dbdc7100059b3370446da30f.tar.gz
Update to 1.4.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch23
-rw-r--r--qtmultimediadefs.patch13
4 files changed, 36 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc22841c586..1c81955e27d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 12 08:21:08 UTC 2017
+# Wed Apr 4 09:03:05 UTC 2018
pkgbase = openboard-develop
pkgdesc = Interactive whiteboard software for schools and universities
- pkgver = 1.3.5
- pkgrel = 4
+ pkgver = 1.4.0
+ pkgrel = 1
url = http://openboard.ch/index.en.html
arch = x86_64
arch = i686
@@ -17,17 +17,17 @@ pkgbase = openboard-develop
depends = libpaper
depends = bzip2
depends = openssl-1.0
- source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.3.5.tar.gz
+ source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.4.0.tar.gz
source = https://github.com/OpenBoard-org/OpenBoard-ThirdParty/archive/master.zip
source = ssl10.patch
source = qchar.patch
- source = qtmultimediadefs.patch
+ source = ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
source = openboard.desktop
- md5sums = d3ff4e88b5c8f1913c12a7686ef86329
+ md5sums = bc04b7178828a6a76dcc7b273276ad30
md5sums = fa1ff089f0bcc15d2a510bb90cdd3002
md5sums = 9dbccb56e4079b75c606dc40c3e77f00
md5sums = bf2c524f3897cfcfb4315bcd92d4206e
- md5sums = 0d18be8088442762c2a3d5e6e1f1a911
+ md5sums = c8c6821f192993626986e60032d2ea41
md5sums = 21d1749400802f8fc0669feaf77de683
pkgname = openboard-develop
diff --git a/PKGBUILD b/PKGBUILD
index 4636f4c720ab..a4d170c48736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=openboard-develop
-pkgver=1.3.5
-pkgrel=4
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Interactive whiteboard software for schools and universities"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
@@ -11,13 +11,13 @@ source=("https://github.com/OpenBoard-org/OpenBoard/archive/v$pkgver.tar.gz"
"https://github.com/OpenBoard-org/OpenBoard-ThirdParty/archive/master.zip"
ssl10.patch
qchar.patch
- qtmultimediadefs.patch
+ ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
openboard.desktop)
-md5sums=('d3ff4e88b5c8f1913c12a7686ef86329'
+md5sums=('bc04b7178828a6a76dcc7b273276ad30'
'fa1ff089f0bcc15d2a510bb90cdd3002'
'9dbccb56e4079b75c606dc40c3e77f00'
'bf2c524f3897cfcfb4315bcd92d4206e'
- '0d18be8088442762c2a3d5e6e1f1a911'
+ 'c8c6821f192993626986e60032d2ea41'
'21d1749400802f8fc0669feaf77de683')
prepare() {
@@ -27,7 +27,7 @@ prepare() {
cd $srcdir/OpenBoard-$pkgver
patch -p1 < $srcdir/ssl10.patch
patch -p1 < $srcdir/qchar.patch
- patch -p1 < $srcdir/qtmultimediadefs.patch
+ patch -p1 < $srcdir/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
}
build() {
diff --git a/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch b/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
new file mode 100644
index 000000000000..12e57d1972fe
--- /dev/null
+++ b/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
@@ -0,0 +1,23 @@
+From ec88fc43aa96bedae1ad32d07e0237fe6fb940b1 Mon Sep 17 00:00:00 2001
+From: fsiegert <frank.siegert@cern.ch>
+Date: Wed, 4 Apr 2018 10:10:55 +0200
+Subject: [PATCH] Fix compilation when LIBAVFORMAT_VERSION_MICRO==100
+
+Since UBFFmpegVideoEncoder.cpp uses `avresample.h` for `LIBAVFORMAT_VERSION_MICRO<100` we have to be complementary here in the include file when including `swresample.h`.
+---
+ src/podcast/ffmpeg/UBFFmpegVideoEncoder.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h b/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
+index 6068a369..69fa81ef 100644
+--- a/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
++++ b/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
+@@ -36,7 +36,7 @@ extern "C" {
+ #include <libswscale/swscale.h>
+
+ // Due to the whole ffmpeg / libAV silliness, we have to support libavresample on some platforms
+-#if LIBAVFORMAT_VERSION_MICRO > 100
++#if LIBAVFORMAT_VERSION_MICRO >= 100
+ #include <libswresample/swresample.h>
+ #else
+ #include <libavresample/avresample.h>
diff --git a/qtmultimediadefs.patch b/qtmultimediadefs.patch
deleted file mode 100644
index 76469af18da3..000000000000
--- a/qtmultimediadefs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -u -ubr a/src/domain/UBGraphicsMediaItemDelegate.h b/src/domain/UBGraphicsMediaItemDelegate.h
---- a/src/domain/UBGraphicsMediaItemDelegate.h 2017-05-09 16:15:51.919921697 +0200
-+++ b/src/domain/UBGraphicsMediaItemDelegate.h 2017-05-09 16:08:00.763830080 +0200
-@@ -32,7 +32,8 @@
-
- #include <QtGui>
- #include <QTimer>
--#include <QtMultimedia>
-+//#include <QtMultimedia>
-+#include <QMediaPlayer>
-
- #include "core/UB.h"
- #include "UBGraphicsItemDelegate.h"