summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-04-14 16:40:47 +0200
committerbartus2021-04-14 16:40:47 +0200
commit98344ea45fb669548ebefe8bfdbcf6358d6cff9b (patch)
treef99673e32a840ad4625e4d11dd538932f992c1ff
parent4f9f15aa99fc3214b56dba06e595f23ef83d388e (diff)
downloadaur-98344ea45fb669548ebefe8bfdbcf6358d6cff9b.tar.gz
Drop upstream applied patches: popple, qwebkit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--poppler.patch124
-rw-r--r--qwebkit.patch12
4 files changed, 1 insertions, 148 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6581f2bb72e9..354a16f72387 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,18 +23,14 @@ pkgbase = openboard-git
depends = poppler
source = git://github.com/OpenBoard-org/OpenBoard.git#branch=master
source = qchar.patch
- source = qwebkit.patch
source = openboard.desktop
source = quazip.patch
- source = poppler.patch
source = drop_ThirdParty_repo.patch
source = 30fps.patch
sha256sums = SKIP
sha256sums = b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549
- sha256sums = 8e276fe7da7a47d5520ce50b5bd761f4e983230629e48dea6d5cfa86b49ca889
sha256sums = 00688af02006bddeab797f624e5cbae66a5c02f4e14315d87d3f198f74797c17
sha256sums = 5a0ccf85dd9f9a05b20fc5cd088181d7c378d2e68dbe789fdf124a607ea2cda7
- sha256sums = af3fd5ad142216242ec30e2ba8f19cc0afb9325fe6ddfae735f53fffdc03137f
sha256sums = 71a41ecbecb952b402d554aa7c5659650765b692662a28f9db904c7390f8f080
sha256sums = 205062adbbd48d6622341e316e14a5496f73696385a3ed5cda7a89d3e7d2861d
diff --git a/PKGBUILD b/PKGBUILD
index cd163e353f76..8064426a551b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,19 +15,14 @@ depends+=(poppler) #replace xpdf lib with poppler, simplify the package and remo
makedepends=(git)
source=("git://github.com/OpenBoard-org/OpenBoard.git${_fragment}"
qchar.patch
- qwebkit.patch
- openboard.desktop
-)
+ openboard.desktop)
source+=(quazip.patch)
-source+=(poppler.patch)
source+=(drop_ThirdParty_repo.patch)
source+=(30fps.patch)
sha256sums=('SKIP'
'b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549'
- '8e276fe7da7a47d5520ce50b5bd761f4e983230629e48dea6d5cfa86b49ca889'
'00688af02006bddeab797f624e5cbae66a5c02f4e14315d87d3f198f74797c17'
'c2772db9b3f0265ba1a54761452f628182369afea1a2d127ea8dae3ff2a139c3'
- 'af3fd5ad142216242ec30e2ba8f19cc0afb9325fe6ddfae735f53fffdc03137f'
'71a41ecbecb952b402d554aa7c5659650765b692662a28f9db904c7390f8f080'
'205062adbbd48d6622341e316e14a5496f73696385a3ed5cda7a89d3e7d2861d')
@@ -40,9 +35,7 @@ prepare() {
cd "$srcdir/OpenBoard"
patch -p1 < $srcdir/drop_ThirdParty_repo.patch
patch -p1 < $srcdir/qchar.patch
- patch -p1 < $srcdir/qwebkit.patch
patch -p1 < $srcdir/quazip.patch
- patch -p1 < $srcdir/poppler.patch
}
build() {
diff --git a/poppler.patch b/poppler.patch
deleted file mode 100644
index 24af8b64d8d9..000000000000
--- a/poppler.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-diff --git a/OpenBoard.pro b/OpenBoard.pro
-index b8a7ae5..0dcf3b8 100644
---- a/OpenBoard.pro
-+++ b/OpenBoard.pro
-@@ -3,6 +3,7 @@ TEMPLATE = app
-
- THIRD_PARTY_PATH=../OpenBoard-ThirdParty
-
-+CONFIG += c++14
- CONFIG -= flat
- CONFIG += debug_and_release \
- no_include_pwd
-diff --git a/src/pdf/XPDFRenderer.cpp b/src/pdf/XPDFRenderer.cpp
-index a3e828e..a77ee49 100644
---- a/src/pdf/XPDFRenderer.cpp
-+++ b/src/pdf/XPDFRenderer.cpp
-@@ -32,6 +32,7 @@
- #include <QtGui>
-
- #include <frameworks/UBPlatformUtils.h>
-+#include <poppler/cpp/poppler-version.h>
-
- #include "core/memcheck.h"
-
-@@ -47,11 +48,15 @@ XPDFRenderer::XPDFRenderer(const QString &filename, bool importingFile)
- {
- // globalParams must be allocated once and never be deleted
- // note that this is *not* an instance variable of this XPDFRenderer class
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
-+ globalParams = std::make_unique<GlobalParams>();
-+#else
- globalParams = new GlobalParams(0);
-+#endif
- globalParams->setupBaseFonts(QFile::encodeName(UBPlatformUtils::applicationResourcesDirectory() + "/" + "fonts").data());
- }
-
-- mDocument = new PDFDoc(new GString(filename.toLocal8Bit()), 0, 0, 0); // the filename GString is deleted on PDFDoc desctruction
-+ mDocument = new PDFDoc(new GooString(filename.toLocal8Bit()), 0, 0, 0); // the filename GString is deleted on PDFDoc desctruction
- sInstancesCount.ref();
- }
-
-@@ -70,8 +75,12 @@ XPDFRenderer::~XPDFRenderer()
-
- if (sInstancesCount.loadAcquire() == 0 && globalParams)
- {
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
-+ globalParams.reset();
-+#else
- delete globalParams;
- globalParams = 0;
-+#endif
- }
- }
-
-@@ -99,16 +108,28 @@ QString XPDFRenderer::title() const
- {
- if (isValid())
- {
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 55
-+ Object pdfInfo = mDocument->getDocInfo();
-+#else
- Object pdfInfo;
- mDocument->getDocInfo(&pdfInfo);
-+#endif
- if (pdfInfo.isDict())
- {
-- Object title;
- Dict *infoDict = pdfInfo.getDict();
-- if (infoDict->lookup((char*)"Title", &title)->isString())
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 55
-+ Object title = infoDict->lookup((char*)"Title");
-+#else
-+ Object title;
-+ infoDict->lookup((char*)"Title", &title);
-+#endif
-+ if (title.isString())
- {
-- GString *gstring = title.getString();
-- return QString(gstring->getCString());
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 72
-+ return QString(title.getString()->c_str());
-+#else
-+ return QString(title.getString()->getCString());
-+#endif
- }
- }
- }
-@@ -172,12 +193,12 @@ QImage* XPDFRenderer::createPDFImage(int pageNumber, qreal xscale, qreal yscale,
- SplashColor paperColor = {0xFF, 0xFF, 0xFF}; // white
- if(mSplash)
- delete mSplash;
-- mSplash = new SplashOutputDev(splashModeRGB8, 1, gFalse, paperColor);
-- mSplash->startDoc(mDocument->getXRef());
-+ mSplash = new SplashOutputDev(splashModeRGB8, 1, false, paperColor);
-+ mSplash->startDoc(mDocument);
- int rotation = 0; // in degrees (get it from the worldTransform if we want to support rotation)
-- GBool useMediaBox = gFalse;
-- GBool crop = gTrue;
-- GBool printing = gFalse;
-+ bool useMediaBox = false;
-+ bool crop = true;
-+ bool printing = false;
- mSliceX = 0.;
- mSliceY = 0.;
-
-diff --git a/src/pdf/XPDFRenderer.h b/src/pdf/XPDFRenderer.h
-index 8ab200bc..003a2055 100644
---- a/src/pdf/XPDFRenderer.h
-+++ b/src/pdf/XPDFRenderer.h
-@@ -36,10 +36,10 @@
- #include "globals/UBGlobals.h"
-
- THIRD_PARTY_WARNINGS_DISABLE
--#include <xpdf/Object.h>
--#include <xpdf/GlobalParams.h>
--#include <xpdf/SplashOutputDev.h>
--#include <xpdf/PDFDoc.h>
-+#include <poppler/Object.h>
-+#include <poppler/GlobalParams.h>
-+#include <poppler/SplashOutputDev.h>
-+#include <poppler/PDFDoc.h>
- THIRD_PARTY_WARNINGS_ENABLE
-
- class PDFDoc;
diff --git a/qwebkit.patch b/qwebkit.patch
deleted file mode 100644
index 6e8d0d8887fc..000000000000
--- a/qwebkit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -ubr a/resources/forms/trapFlash.ui b/resources/forms/trapFlash.ui
---- a/resources/forms/trapFlash.ui 2017-05-09 15:59:42.177965830 +0200
-+++ b/resources/forms/trapFlash.ui 2017-05-09 16:00:08.547747097 +0200
-@@ -113,7 +113,7 @@
- <customwidget>
- <class>QWebView</class>
- <extends>QWidget</extends>
-- <header>QtWebKit/QWebView</header>
-+ <header>QtWebKitWidgets/QWebView</header>
- </customwidget>
- </customwidgets>
- <resources/>