summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Appelman2019-01-06 20:18:24 +0100
committerRobin Appelman2019-01-06 20:18:24 +0100
commitf86095eba523a21ddb3616b467b56ab3ec29bd40 (patch)
treec3af345f2cbac5e4a7314f352e8d4d3b3e10a9f0
parent0251ea86073250da90d5e2809ac807753b8decd2 (diff)
downloadaur-f86095eba523a21ddb3616b467b56ab3ec29bd40.tar.gz
adjust to inflex version and update glad
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e690f1781a78..e25a3bbb1c4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = openboardview
+pkgbase = openboardview-inflex
pkgdesc = Linux SDL/ImGui edition software for viewing .brd files
- pkgver = 7.3
+ pkgver = 2018062301
pkgrel = 1
url = https://openboardview.org/
arch = i686
@@ -8,14 +8,18 @@ pkgbase = openboardview
license = MIT
makedepends = git
makedepends = cmake
+ makedepends = python
depends = sdl2
depends = sqlite
depends = zlib
depends = fontconfig
depends = gtk3
depends = libpng
- source = git+https://github.com/OpenBoardView/OpenBoardView.git#tag=R7.3
+ conflicts = openboardview
+ source = git+https://github.com/inflex/OpenBoardView.git#tag=R2018062301
+ source = https://github.com/Dav1dde/glad/archive/v0.1.28.zip
sha512sums = SKIP
+ sha512sums = 46fade309d4c2803cb9d0e15e4c2416fc31973649f2d5860b6f57f36b4495c33d386e0fc2244d9ea0bee8070ca9b3874cd23ac50d9f95370c6bdede870baaece
-pkgname = openboardview
+pkgname = openboardview-inflex
diff --git a/PKGBUILD b/PKGBUILD
index edf63f8844e3..58a9decef20f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+# Maintainer: Robin Appelman <robin@icewind.nl>
-_pkgname=OpenBoardView
+_pkgbase=OpenBoardView
+_pkgname=OpenBoardView-inflex
+_glad_version='0.1.28'
pkgname=${_pkgname,,}
-pkgver=7.3
+pkgver=2018062301
pkgrel=1
pkgdesc='Linux SDL/ImGui edition software for viewing .brd files'
arch=('i686' 'x86_64')
url='https://openboardview.org/'
license=('MIT')
depends=('sdl2' 'sqlite' 'zlib' 'fontconfig' 'gtk3' 'libpng')
-makedepends=('git' 'cmake')
-source=("git+https://github.com/OpenBoardView/OpenBoardView.git#tag=R${pkgver}")
-sha512sums=('SKIP')
+makedepends=('git' 'cmake' 'python')
+conflicts=('openboardview')
+source=("git+https://github.com/inflex/OpenBoardView.git#tag=R${pkgver}" "https://github.com/Dav1dde/glad/archive/v${_glad_version}.zip")
+sha512sums=('SKIP'
+ '46fade309d4c2803cb9d0e15e4c2416fc31973649f2d5860b6f57f36b4495c33d386e0fc2244d9ea0bee8070ca9b3874cd23ac50d9f95370c6bdede870baaece')
+
+prepare() {
+ cd "${srcdir}"
+ rm -r "${_pkgbase}/src/glad"
+ mv "glad-${_glad_version}" "${_pkgbase}/src/glad"
+}
build() {
- mkdir -p "${srcdir}/${_pkgname}/build"
- cd "${srcdir}/${_pkgname}/build"
+ mkdir -p "${srcdir}/${_pkgbase}/build"
+ cd "${srcdir}/${_pkgbase}/build"
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgbase}"
install -Dm755 build/src/openboardview/openboardview "${pkgdir}/usr/bin/openboardview"
install -Dm755 utilities/bvconv.sh "${pkgdir}/usr/bin/bvconv"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"