summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-08-31 01:45:06 +0200
committerCarsten Teibes2015-08-31 01:45:06 +0200
commit48959eb1743bbde9ebf828337575db15b9425392 (patch)
tree0c4bce8fbd6384a412f9d57bead97f27648856af
parentab8dca9efa1ef5037a082d4fba89bb8e9601c348 (diff)
downloadaur-48959eb1743bbde9ebf828337575db15b9425392.tar.gz
[upd] Now depends on sdl2
[fix] Remove type redefinition
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8806e4eae35..db6ae5a7776d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openbor-svn
pkgdesc = An open source fighting video game and moddable game engine (aka Beats of Rage)
- pkgver = 3.0.r4107
+ pkgver = 3.0.r4165
pkgrel = 1
url = http://www.chronocrash.com
install = openbor.install
@@ -12,10 +12,13 @@ pkgbase = openbor-svn
makedepends = imagemagick
makedepends = glu
depends = bash
- depends = sdl_gfx
+ depends = sdl2_gfx
depends = libvorbis
depends = libpng
+ depends = libvpx
optdepends = libgl: OpenGL video mode
+ provides = openbor
+ conflicts = openbor
source = openbor::svn+http://svn.code.sf.net/p/openbor/engine/engine
source = openbor.desktop
source = openbor.sh
diff --git a/PKGBUILD b/PKGBUILD
index 151d7f6ddc40..d819eb58d898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,15 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=openbor-svn
-pkgver=3.0.r4107
+pkgver=3.0.r4165
pkgrel=1
pkgdesc="An open source fighting video game and moddable game engine (aka Beats of Rage)"
arch=('i686' 'x86_64')
url="http://www.chronocrash.com"
license=('BSD')
-depends=('bash' 'sdl_gfx' 'libvorbis' 'libpng')
+provides=("openbor")
+conflicts=("openbor")
+depends=('bash' 'sdl2_gfx' 'libvorbis' 'libpng' 'libvpx')
makedepends=('subversion' 'yasm' 'imagemagick' 'glu')
optdepends=('libgl: OpenGL video mode')
install=openbor.install
@@ -33,7 +35,7 @@ pkgver() {
prepare() {
cd openbor
- # disable abort on error
+ # disable abort on warnings/errors
sed 's/-Werror//' -i Makefile
# disable RPATH
sed 's/-Wl,-rpath,$(LIBRARIES)//' -i Makefile
@@ -43,12 +45,15 @@ prepare() {
sed 's|en_US.UTF-8|C|g' -i version.sh
# convert icon
convert -resize 48x48 resources/OpenBOR_Icon_128x128.png ../openbor.png
+
+ # FIXME: wipe file so it does not redefine max_align_t
+ echo "" > source/webmlib/halloc/align.h
}
build() {
cd openbor
- # work around broken build system
+ # work around 'special' build system
./version.sh
make SDKPATH=/usr LNXDEV=/usr/bin BUILD_LINUX=1 GCC_TARGET=$CARCH
}