summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Filion2024-01-27 21:19:00 -0500
committerMartin Filion2024-01-27 21:19:00 -0500
commit52d1023940a0ae1b975deb791b22952310da6df8 (patch)
tree56e0737f9c5f436301d148cf6d9dcdc69fa28784
parent0b63e79f781f7bb03e62fe94cf213e89a601027e (diff)
downloadaur-openbox-menu.tar.gz
added lxterminal as dep. include patches to have lxterminal instead of xterm for terminal apps
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--menu.patch11
-rw-r--r--openbox-menu.patch11
4 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dc66ccad3b0..91d873f25da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = openbox-menu
pkgdesc = Dynamic XDG menu for openbox
pkgver = 0.8.0
- pkgrel = 1
+ pkgrel = 2
url = http://fabrice.thiroux.free.fr/openbox-menu_en.html
arch = i686
arch = x86_64
license = GPL3
depends = gtk2
depends = menu-cache
+ depends = lxterminal
optdepends = lxmenu-data: LXDE menus
optdepends = gnome-menus: GNOME menus
source = git+https://github.com/fabriceT/openbox-menu
source = with-svg.patch
+ source = openbox-menu.patch
+ source = menu.patch
md5sums = SKIP
md5sums = 484bd49f619e57f9fb2be42931d57dd5
+ md5sums = 1a74746fcf8b24f76fc79c61d1533db0
+ md5sums = 5d92e49ed689ada8b2a02b04cc50a4b0
pkgname = openbox-menu
diff --git a/PKGBUILD b/PKGBUILD
index b5cc6729ce2a..2897a2fe0d64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Contributors: Calimero <calimeroteknik@free.fr>
# Maintainer: mimas <mimasgpc@free.fr>
-# Last Modified 2023-01-23 by Martin Filion <Mordillo98@gmail.com>
+# Last Modified 2024-01-27 by Martin Filion <Mordillo98@gmail.com>
pkgname=openbox-menu
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic XDG menu for openbox"
arch=('i686' 'x86_64')
url="http://fabrice.thiroux.free.fr/openbox-menu_en.html"
license=('GPL3')
-depends=('gtk2' 'menu-cache')
+depends=('gtk2' 'menu-cache' 'lxterminal')
optdepends=('lxmenu-data: LXDE menus' 'gnome-menus: GNOME menus')
-source=("git+https://github.com/fabriceT/openbox-menu" "with-svg.patch")
+source=("git+https://github.com/fabriceT/openbox-menu" "with-svg.patch" "openbox-menu.patch" "menu.patch")
md5sums=('SKIP'
- '484bd49f619e57f9fb2be42931d57dd5')
+ '484bd49f619e57f9fb2be42931d57dd5'
+ '1a74746fcf8b24f76fc79c61d1533db0'
+ '5d92e49ed689ada8b2a02b04cc50a4b0')
build() {
cd "${srcdir}/${pkgname}"
patch -i ../with-svg.patch
+
+ # Uses Lxterminal instead of xterm for terminal apps.
+ patch src/menu.c < ../menu.patch
+ patch src/openbox-menu.h < ../openbox-menu.patch
+
make
}
diff --git a/menu.patch b/menu.patch
new file mode 100644
index 000000000000..a4d78f3a95f8
--- /dev/null
+++ b/menu.patch
@@ -0,0 +1,11 @@
+--- src/menu.c 2024-01-27 20:51:58.404201044 -0500
++++ src/menu_new.c 2024-01-27 20:53:08.418207591 -0500
+@@ -93,7 +93,7 @@
+ { "comment", 'c', 0, G_OPTION_ARG_NONE, &comment,
+ "Show generic name instead of application name", NULL },
+ { "terminal", 't', 0, G_OPTION_ARG_STRING, &terminal_cmd,
+- "Terminal command (default xterm -e)", "cmd" },
++ "Terminal command (default lxterminal -e)", "cmd" },
+ { "gnome", 'g', 0, G_OPTION_ARG_NONE, &show_gnome,
+ "Show GNOME entries", NULL },
+ { "kde", 'k', 0, G_OPTION_ARG_NONE, &show_kde,
diff --git a/openbox-menu.patch b/openbox-menu.patch
new file mode 100644
index 000000000000..3bea70e8835a
--- /dev/null
+++ b/openbox-menu.patch
@@ -0,0 +1,11 @@
+--- src/openbox-menu.h 2024-01-27 20:53:54.778657651 -0500
++++ src/openbox-menu_new.h 2024-01-27 20:55:16.852795097 -0500
+@@ -28,7 +28,7 @@
+
+ #define VERSION "0.8.1"
+ #define APPMENU_SIZE 30
+-#define TERMINAL_CMD "xterm -e"
++#define TERMINAL_CMD "lxterminal -e"
+
+ #ifndef __VERSION_MINOR // since menu-cache 0.5.0.
+ #warning "If you are running a 0.3.x version of libmenu-cache, you need to compile the 3.6.7 version of openbox-menu"