summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswyter2021-08-18 09:47:20 +0200
committerswyter2021-08-18 09:47:20 +0200
commite50da5fdb7d622e164c32bb6915b6dac497810ee (patch)
tree2a84a2dcb54337fbb991b84dea7e7c839c755012
parent97232df7a4378824a1fb4d547529bcd712c0173f (diff)
downloadaur-openbrf.tar.gz
Don't make the thread count zero (-j 0) when there's only one available core (due to the system-threads - 1 thing).
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f50c416849d7..a1d4e7f74441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,7 @@ build()
# build it as fast as possible, but leaving a free CPU core for other stuff!
qmake -makefile openBrf.pro
- make -j $[`nproc` - 1]
+ make -j $[ (n = `nproc` - 1) < 1 ? 1 : n ] # swy: don't make the thread count zero (-j 0) when there's only one available core (due to the system-threads - 1 thing)
}
package()