summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2015-07-03 15:18:56 +0200
committerBalló György2015-07-03 15:18:56 +0200
commit05950e7595b221342f441519fcd748f6b21a1501 (patch)
treebdc09f208868ecfcfe3a6b5736106b14760905c0
downloadaur-05950e7595b221342f441519fcd748f6b21a1501.tar.gz
upgpkg: openbve 1.4.3-2
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD58
-rw-r--r--openbve.desktop11
-rw-r--r--openbve.sh2
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf1f26a1ad30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = openbve
+ pkgdesc = Free-as-in-freedom train simulator placed in the public domain
+ pkgver = 1.4.3
+ pkgrel = 2
+ url = http://odakyufan.zxq.net/openbve/
+ arch = any
+ license = custom:public domain
+ depends = mono
+ depends = taoframework
+ depends = sdl
+ depends = openal
+ source = http://pkgbuild.com/~bgyorgy/sources/openbve-1.4.3.tar.gz
+ source = openbve.sh
+ source = openbve.desktop
+ md5sums = ea665ae920add94157b1f49e8e685c56
+ md5sums = fec92946f773f56588a71de310847ce0
+ md5sums = acb0dd3ea602910181b8cdb8375c794e
+
+pkgname = openbve
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3fc643b7763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=openbve
+pkgver=1.4.3
+pkgrel=2
+pkgdesc="Free-as-in-freedom train simulator placed in the public domain"
+arch=('any')
+url="http://odakyufan.zxq.net/openbve/"
+license=('custom:public domain')
+depends=('mono' 'taoframework' 'sdl' 'openal')
+source=(http://pkgbuild.com/~bgyorgy/sources/$pkgname-$pkgver.tar.gz
+ $pkgname.sh
+ $pkgname.desktop)
+md5sums=('ea665ae920add94157b1f49e8e685c56'
+ 'fec92946f773f56588a71de310847ce0'
+ 'acb0dd3ea602910181b8cdb8375c794e')
+
+build() {
+ cd $pkgname-$pkgver/SourceCode/openBVE
+ xbuild /p:Configuration=Release OpenBve/OpenBve.csproj
+ xbuild /p:Configuration=Release OpenBveAts/OpenBveAts.csproj
+ xbuild /p:Configuration=Release Sound.Flac/Sound.Flac.csproj
+ xbuild /p:Configuration=Release Sound.RiffWave/Sound.RiffWave.csproj
+ xbuild /p:Configuration=Release Texture.Ace/Texture.Ace.csproj
+ xbuild /p:Configuration=Release Texture.BmpGifJpegPngTiff/Texture.BmpGifJpegPngTiff.csproj
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ # Data
+ install -dm755 "$pkgdir/usr/lib/$pkgname/"
+ install -dm755 "$pkgdir/usr/share/games/$pkgname/"
+ cp -r Data "$pkgdir/usr/share/games/$pkgname/"
+ ln -s ../../share/games/$pkgname/Data "$pkgdir/usr/lib/$pkgname/Data"
+ chmod 755 "$pkgdir"/usr/lib/$pkgname/Data/Compatibility/{PreTrain,Signals/Graphics}
+
+ # Binaries
+ install -d "$pkgdir/usr/lib/$pkgname/"
+ install -Dm644 SourceCode/openBVE/OpenBve/bin/Release/OpenBve.exe "$pkgdir/usr/lib/$pkgname/"
+ install -Dm644 SourceCode/openBVE/OpenBve/bin/Release/OpenBveApi.dll "$pkgdir/usr/lib/$pkgname/"
+ install -Dm644 SourceCode/openBVE/OpenBveAts/bin/Release/OpenBveAts.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
+ install -Dm644 SourceCode/openBVE/Sound.Flac/bin/Release/Sound.Flac.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
+ install -Dm644 SourceCode/openBVE/Sound.RiffWave/bin/Release/Sound.RiffWave.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
+ install -Dm644 SourceCode/openBVE/Texture.Ace/bin/Release/Texture.Ace.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
+ install -Dm644 SourceCode/openBVE/Texture.BmpGifJpegPngTiff/bin/Release/Texture.BmpGifJpegPngTiff.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
+
+ # Executable
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # Desktop file and icon
+ install -Dm644 "$srcdir/$pkgname.desktop" $pkgdir/usr/share/applications/$pkgname.desktop
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ ln -s ../games/$pkgname/Data/Menu/logo.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ # License
+ install -Dm644 Credits.txt "$pkgdir/usr/share/licenses/$pkgname/Credits.txt"
+}
diff --git a/openbve.desktop b/openbve.desktop
new file mode 100644
index 000000000000..ca83db1df254
--- /dev/null
+++ b/openbve.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=OpenBVE
+Categories=Game;Simulation;
+Comment=Train/railway simulator compatible with 'BVE Trainsim' routes
+Comment[hu]=A „BVE Trainsim” útvonalaival kompatibilis vonatszimulátor
+Terminal=false
+TryExec=openbve
+Exec=openbve
+Icon=openbve
diff --git a/openbve.sh b/openbve.sh
new file mode 100644
index 000000000000..4bd56d02709d
--- /dev/null
+++ b/openbve.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+mono /usr/lib/openbve/OpenBve.exe /fhs "$@"