summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-04-13 09:45:40 +0200
committerBalló György2016-04-13 09:45:40 +0200
commit2f832a574e56913de68acb4f9a87e646a4fd2f30 (patch)
tree01af885ed7f35236ed2ee33af6b12ed50cf14810
parent05950e7595b221342f441519fcd748f6b21a1501 (diff)
downloadaur-2f832a574e56913de68acb4f9a87e646a4fd2f30.tar.gz
upgpkg: openbve 1.4.3-3
New upstream source, update to latest git revision
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 30 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf1f26a1ad30..502f4d3da42b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Apr 13 07:45:40 UTC 2016
pkgbase = openbve
pkgdesc = Free-as-in-freedom train simulator placed in the public domain
pkgver = 1.4.3
- pkgrel = 2
- url = http://odakyufan.zxq.net/openbve/
+ pkgrel = 3
+ url = https://github.com/leezer3/OpenBVE
arch = any
+ license = MIT
license = custom:public domain
+ depends = libxi
depends = mono
- depends = taoframework
- depends = sdl
depends = openal
- source = http://pkgbuild.com/~bgyorgy/sources/openbve-1.4.3.tar.gz
+ source = https://github.com/leezer3/OpenBVE/archive/f9d51d9e75530e8e685b35bf7185fe6ff90c23fc.tar.gz
source = openbve.sh
source = openbve.desktop
- md5sums = ea665ae920add94157b1f49e8e685c56
- md5sums = fec92946f773f56588a71de310847ce0
- md5sums = acb0dd3ea602910181b8cdb8375c794e
+ sha256sums = 078d3153769527988e5c457241eb2f4cb68618a275d9217b53832924b018acf4
+ sha256sums = b65ab9522b920fa2750d0cdfddcf54db4b6b814f6f61cbff6553dccba0c7d6e0
+ sha256sums = 89752bcd843b3e14c22ee73560c12fe3b3afc06d89891cdb80b80fc7fd7b5f38
pkgname = openbve
diff --git a/PKGBUILD b/PKGBUILD
index a3fc643b7763..6d1720f43a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,38 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
pkgname=openbve
+_pkgname=OpenBVE
pkgver=1.4.3
-pkgrel=2
+_gitrev=f9d51d9e75530e8e685b35bf7185fe6ff90c23fc
+pkgrel=3
pkgdesc="Free-as-in-freedom train simulator placed in the public domain"
arch=('any')
-url="http://odakyufan.zxq.net/openbve/"
-license=('custom:public domain')
-depends=('mono' 'taoframework' 'sdl' 'openal')
-source=(http://pkgbuild.com/~bgyorgy/sources/$pkgname-$pkgver.tar.gz
+url="https://github.com/leezer3/OpenBVE"
+license=('MIT' 'custom:public domain')
+depends=('libxi' 'mono' 'openal')
+source=(https://github.com/leezer3/$_pkgname/archive/$_gitrev.tar.gz
$pkgname.sh
$pkgname.desktop)
-md5sums=('ea665ae920add94157b1f49e8e685c56'
- 'fec92946f773f56588a71de310847ce0'
- 'acb0dd3ea602910181b8cdb8375c794e')
+sha256sums=('078d3153769527988e5c457241eb2f4cb68618a275d9217b53832924b018acf4'
+ 'b65ab9522b920fa2750d0cdfddcf54db4b6b814f6f61cbff6553dccba0c7d6e0'
+ '89752bcd843b3e14c22ee73560c12fe3b3afc06d89891cdb80b80fc7fd7b5f38')
build() {
- cd $pkgname-$pkgver/SourceCode/openBVE
+ cd $_pkgname-$_gitrev/openBVE
xbuild /p:Configuration=Release OpenBve/OpenBve.csproj
- xbuild /p:Configuration=Release OpenBveAts/OpenBveAts.csproj
- xbuild /p:Configuration=Release Sound.Flac/Sound.Flac.csproj
- xbuild /p:Configuration=Release Sound.RiffWave/Sound.RiffWave.csproj
- xbuild /p:Configuration=Release Texture.Ace/Texture.Ace.csproj
- xbuild /p:Configuration=Release Texture.BmpGifJpegPngTiff/Texture.BmpGifJpegPngTiff.csproj
}
package() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$_gitrev/openBVE
- # Data
+ # Binaries
install -dm755 "$pkgdir/usr/lib/$pkgname/"
+ cp -r OpenBve/bin/Release/* "$pkgdir/usr/lib/$pkgname/"
+
+ # Data
install -dm755 "$pkgdir/usr/share/games/$pkgname/"
- cp -r Data "$pkgdir/usr/share/games/$pkgname/"
+ mv "$pkgdir/usr/lib/$pkgname/Data" "$pkgdir/usr/share/games/$pkgname/"
ln -s ../../share/games/$pkgname/Data "$pkgdir/usr/lib/$pkgname/Data"
- chmod 755 "$pkgdir"/usr/lib/$pkgname/Data/Compatibility/{PreTrain,Signals/Graphics}
-
- # Binaries
- install -d "$pkgdir/usr/lib/$pkgname/"
- install -Dm644 SourceCode/openBVE/OpenBve/bin/Release/OpenBve.exe "$pkgdir/usr/lib/$pkgname/"
- install -Dm644 SourceCode/openBVE/OpenBve/bin/Release/OpenBveApi.dll "$pkgdir/usr/lib/$pkgname/"
- install -Dm644 SourceCode/openBVE/OpenBveAts/bin/Release/OpenBveAts.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
- install -Dm644 SourceCode/openBVE/Sound.Flac/bin/Release/Sound.Flac.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
- install -Dm644 SourceCode/openBVE/Sound.RiffWave/bin/Release/Sound.RiffWave.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
- install -Dm644 SourceCode/openBVE/Texture.Ace/bin/Release/Texture.Ace.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
- install -Dm644 SourceCode/openBVE/Texture.BmpGifJpegPngTiff/bin/Release/Texture.BmpGifJpegPngTiff.dll "$pkgdir/usr/lib/$pkgname/Data/Plugins/"
# Executable
install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
@@ -54,5 +43,7 @@ package() {
ln -s ../games/$pkgname/Data/Menu/logo.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
# License
- install -Dm644 Credits.txt "$pkgdir/usr/share/licenses/$pkgname/Credits.txt"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m644 ../CSSCriptLicence.txt ../OpenTKLicence.txt ../Readme.md ../SharpCompressLicence.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}