summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Bertelli2022-06-24 12:26:30 -0300
committerFilipe Bertelli2022-06-24 12:26:30 -0300
commita5c3eec076d639c7fc5a4f9b73f481f3f88f827d (patch)
tree0ea351d7fe07b2dcdde930054ecb3ea6876dad61
downloadaur-a5c3eec076d639c7fc5a4f9b73f481f3f88f827d.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e6cfa52c738
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = openbve-bin
+ pkgdesc = Realistic 3D train/railway simulator
+ pkgver = 1.8.3.2
+ pkgrel = 1
+ url = https://github.com/leezer3/OpenBVE
+ arch = x86_64
+ depends = mono
+ source = https://github.com/leezer3/OpenBVE/releases/download/1.8.3.2/OpenBVE-1.8.3.2.deb
+ sha256sums = a3b6b9bc5264e7af3a2aa98735bce6a2ef29f9557b582474c5de0d0f5e6170b8
+
+pkgname = openbve-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e88a18bf6c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: fearlessdots <filipebertelli@tutanota.com>
+# About this software's licensing: <https://github.com/leezer3/OpenBVE/issues/589>
+
+pkgname=openbve-bin
+pkgver=1.8.3.2
+pkgrel=1
+pkgdesc="Realistic 3D train/railway simulator"
+arch=('x86_64')
+url="https://github.com/leezer3/OpenBVE"
+license=()
+depends=('mono')
+source=("https://github.com/leezer3/OpenBVE/releases/download/${pkgver}/OpenBVE-${pkgver}.deb")
+sha256sums=("a3b6b9bc5264e7af3a2aa98735bce6a2ef29f9557b582474c5de0d0f5e6170b8")
+
+package() {
+ # Extract downloaded file
+ tar -xf "$srcdir/data.tar.xz" -C "$pkgdir/"
+
+ # Change game launcher
+ cat "$pkgdir/usr/games/openbve" | sed 's#/usr/bin/cli#/usr/bin/mono#' | tee "$pkgdir/usr/games/openbve"
+
+ # Link executable to /usr/bin
+ install -d "$pkgdir/usr/bin/"
+ ln -sf /usr/games/openbve "$pkgdir/usr/bin/openbve"
+}