summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2023-02-28 12:27:43 -0500
committerAdam Goldsmith2023-02-28 12:27:43 -0500
commita1270d9e1e8ebc5e288f2d6af5ac42db9040e5e3 (patch)
tree1a6747e296285c177f64f828bc2904548a88cb3e
parent073913f94fed5779dcbb6c472d504900d59fcf47 (diff)
downloadaur-opencamlib-git.tar.gz
Fix build to use root `CMakeLists.txt` instead of `src/CMakeLists.txt`
This fixes an issue with `check_ipo_supported` caused by CMP0069 not being set
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eb3f9e873c6..d5fbc0c57f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencamlib-git
pkgdesc = Multi-Purpose CNC Toolpath Library
- pkgver = 2019.07.4.g983a416
+ pkgver = 2023.01.11.4.ge4a5a7d
pkgrel = 1
url = https://github.com/aewallin/opencamlib
arch = i686
@@ -20,4 +20,3 @@ pkgbase = opencamlib-git
md5sums = a47c8358b60c11c4d620e6a0c24c0b50
pkgname = opencamlib-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7af9d9e61572..ce8d8f7a0e1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=opencamlib-git
-pkgver=2019.07.17.g653ef7f
+pkgver=2023.01.11.4.ge4a5a7d
pkgrel=1
pkgdesc="Multi-Purpose CNC Toolpath Library"
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ pkgver() {
build() {
mkdir -p "$srcdir/opencamlib/build"
cd "$srcdir/opencamlib/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_PY_3="ON" -DBUILD_PY_LIB="ON" ../src
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_PY_3="ON" -DBUILD_PY_LIB="ON" ../
make
}