summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-02-18 01:58:09 -0500
committerAdam Goldsmith2020-02-18 01:58:36 -0500
commita3b74e44099ad33fa1b1533e26edd526e793179e (patch)
treeabceb2195f16bd68fbffb8adcae2b83d6fe5b0c2
parent0925a500e4afb45ee34b2d6355dc8975d4e012e8 (diff)
downloadaur-a3b74e44099ad33fa1b1533e26edd526e793179e.tar.gz
Add conf file for ld
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--opencamlib.conf1
3 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ed35389f032..6f5ec4b91f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,9 @@ pkgbase = opencamlib-git
provides = opencamlib
conflicts = opencamlib
source = git+https://github.com/aewallin/opencamlib.git
+ source = opencamlib.conf
md5sums = SKIP
+ md5sums = a47c8358b60c11c4d620e6a0c24c0b50
pkgname = opencamlib-git
diff --git a/PKGBUILD b/PKGBUILD
index 826d56197961..acdf1d8b7066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,10 @@ makedepends=('boost' 'cmake' 'doxygen')
depends=('python' 'boost')
provides=('opencamlib')
conflicts=('opencamlib')
-source=("git+https://github.com/aewallin/opencamlib.git")
-md5sums=('SKIP')
+source=("git+https://github.com/aewallin/opencamlib.git"
+ "opencamlib.conf")
+md5sums=('SKIP'
+ 'a47c8358b60c11c4d620e6a0c24c0b50')
pkgver() {
cd opencamlib
@@ -29,4 +31,5 @@ build() {
package() {
cd "$srcdir/opencamlib/build"
make install DESTDIR=$pkgdir
+ install -Dm644 "$srcdir/opencamlib.conf" "${pkgdir}/etc/ld.so.conf.d/opencamlib.conf"
}
diff --git a/opencamlib.conf b/opencamlib.conf
new file mode 100644
index 000000000000..c347e5cf646f
--- /dev/null
+++ b/opencamlib.conf
@@ -0,0 +1 @@
+/usr/lib/opencamlib