summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-03-12 11:50:49 -0400
committerAdam Goldsmith2017-03-12 11:50:49 -0400
commitb8d1cfe1287224684a0ceb34402a629e7ba6205d (patch)
treec9034cc3b9e91b4dca2b81761d3a61c4efddbe19
parent7c3f534dcc8419f8ed88f19c4c67319543e39ab5 (diff)
downloadaur-b8d1cfe1287224684a0ceb34402a629e7ba6205d.tar.gz
Drop CmakeLists patch entirely, as a fix was merged upstream
-rw-r--r--.SRCINFO6
-rw-r--r--CMakeLists.txt.patch27
-rw-r--r--PKGBUILD13
3 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 186c4f3196b3..f302cb1a79f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 3 08:30:52 UTC 2017
+# Sun Mar 12 15:50:14 UTC 2017
pkgbase = opencamlib-git
pkgdesc = Multi-Purpose CNC Toolpath Library
- pkgver = 11.10.73.g30ed446
+ pkgver = 11.10.84.gc2bcbbd
pkgrel = 1
url = https://github.com/aewallin/opencamlib
arch = i686
@@ -16,9 +16,7 @@ pkgbase = opencamlib-git
provides = opencamlib
conflicts = opencamlib
source = git+https://github.com/aewallin/opencamlib.git
- source = CMakeLists.txt.patch
md5sums = SKIP
- md5sums = 84af9224f4e3929afe447e843094b103
pkgname = opencamlib-git
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
deleted file mode 100644
index 8a59fb6db67f..000000000000
--- a/CMakeLists.txt.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -235,13 +235,13 @@ include_directories( ${OpenCamLib_SOURCE_DIR} )
- #
-
- execute_process(
-- COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0,0,\"/usr/local\")"
-+ COMMAND python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0,0,\"/usr/local\")"
- OUTPUT_VARIABLE Python_site_packages
- OUTPUT_STRIP_TRAILING_WHITESPACE
- ) # on Ubuntu 11.10 this outputs: /usr/local/lib/python2.7/dist-packages
-
- execute_process(
-- COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(plat_specific=1,standard_lib=0,prefix=\"/usr/local\")"
-+ COMMAND python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib(plat_specific=1,standard_lib=0,prefix=\"/usr/local\")"
- OUTPUT_VARIABLE Python_arch_packages
- OUTPUT_STRIP_TRAILING_WHITESPACE
- )
-@@ -428,8 +428,6 @@ IF (DOXYGEN_FOUND)
- ENDIF(DOXYGEN_FOUND)
- endif (BUILD_DOC)
-
--include(${CMAKE_SOURCE_DIR}/deb/package_details.cmake)
--
- # "make spackage"
- add_custom_target(spackage
- ${CMAKE_COMMAND}
diff --git a/PKGBUILD b/PKGBUILD
index a963896136f4..c44f6afb16d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=opencamlib-git
-pkgver=11.10.73.g30ed446
+pkgver=11.10.84.gc2bcbbd
pkgrel=1
pkgdesc="Multi-Purpose CNC Toolpath Library"
arch=('i686' 'x86_64')
@@ -11,23 +11,18 @@ makedepends=('boost' 'cmake' 'doxygen')
depends=('python2' 'boost')
provides=('opencamlib')
conflicts=('opencamlib')
-source=("git+https://github.com/aewallin/opencamlib.git" 'CMakeLists.txt.patch')
-md5sums=('SKIP' '84af9224f4e3929afe447e843094b103')
+source=("git+https://github.com/aewallin/opencamlib.git")
+md5sums=('SKIP')
pkgver() {
cd opencamlib
git describe --tags | sed 's/-/./g'
}
-prepare() {
- cd "$srcdir/opencamlib/src"
- patch < $srcdir/CMakeLists.txt.patch
-}
-
build() {
mkdir "$srcdir/opencamlib/build"
cd "$srcdir/opencamlib/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../src
make
}