summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-03-27 12:54:44 +0100
committerGrey Christoforo2021-03-27 12:54:44 +0100
commitaed28f1bd93bce1af1ef2de6b217e40a377647b6 (patch)
tree3db5a4b87b60625747a34282a708c398d37a5a98
parent700bd29eaa8c3c650ec4f15bc081e56f66e40ff4 (diff)
downloadaur-aed28f1bd93bce1af1ef2de6b217e40a377647b6.tar.gz
fix build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc6c93d47b85..018508cc21d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencascade-git
pkgdesc = An object-oriented C++ class library designed for rapid production of sophisticated domain-specific CAD/CAM/CAE applications.
- pkgver = 7.5.0.r176.gf7ad1e7e3
+ pkgver = 7.5.0.r188.gbbc5899a8c
pkgrel = 1
url = https://dev.opencascade.org/
arch = x86_64
@@ -18,10 +18,8 @@ pkgbase = opencascade-git
depends = intel-tbb
provides = opencascade
conflicts = opencascade
- source = occt::git+https://github.com/Open-Cascade-SAS/OCCT.git
- source = fix-install-dir-references.patch
- md5sums = SKIP
- md5sums = 9614204ad945c1fcfa4c2c058c9d0423
+ source = git+https://git.dev.opencascade.org/repos/occt.git
+ sha256sums = SKIP
pkgname = opencascade-git
diff --git a/PKGBUILD b/PKGBUILD
index 0e0f2bfbbe2f..c928fafc5a43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=opencascade-git
-pkgver=7.5.0.r176.gf7ad1e7e3
+pkgver=7.5.0.r188.gbbc5899a8c
pkgrel=1
pkgdesc="An object-oriented C++ class library designed for rapid production of sophisticated domain-specific CAD/CAM/CAE applications."
arch=(x86_64)
@@ -28,13 +28,10 @@ rapidjson
)
#checkdepends=()
-#source=("git+https://git.dev.opencascade.org/repos/occt.git") # broken today?
source=(
-"occt::git+https://github.com/Open-Cascade-SAS/OCCT.git"
-fix-install-dir-references.patch
+"git+https://git.dev.opencascade.org/repos/occt.git"
)
-md5sums=('SKIP'
- '9614204ad945c1fcfa4c2c058c9d0423')
+sha256sums=('SKIP')
pkgver() {
cd occt
@@ -43,7 +40,6 @@ pkgver() {
prepare() {
cd occt
- patch -Np1 -i "$srcdir/fix-install-dir-references.patch"
# fix for None type build
sed '/OpenCASCADECompileDefinitionsAndFlags/d' -i CMakeLists.txt
@@ -79,13 +75,12 @@ build() {
USE_TBB=ON
USE_VTK=ON
AUX_ARGS=
-
+
cmake -B build_dir -S "occt" \
-W no-dev \
-G Ninja \
- -D CMAKE_BUILD_TYPE='None' \
+ -D CMAKE_BUILD_TYPE=None \
-D CMAKE_INSTALL_PREFIX='/usr' \
- -D 3RDPARTY_DIR:PATH="$OCCT3RDPARTY" \
-D 3RDPARTY_FREETYPE_DIR:PATH="$FREETYPE_DIR" \
-D BUILD_ADDITIONAL_TOOLKITS:STRING="$BUILD_ADDITIONAL_TOOLKITS" \
-D BUILD_DOC_Overview:BOOL=$BUILD_DOC_Overview \
@@ -105,13 +100,18 @@ build() {
-D INSTALL_DIR_LAYOUT:STRING=Unix \
-D INSTALL_DIR_BIN:STRING=$INSTALL_DIR_BIN \
-D INSTALL_DIR_LIB:STRING=$INSTALL_DIR_LIB \
+ -D INSTALL_DIR_CMAKE:PATH=/usr/lib/cmake/opencascade \
-D USE_FFMPEG:BOOL=$USE_FFMPEG \
-D USE_FREEIMAGE:BOOL=$USE_FREEIMAGE \
-D USE_GLES2:BOOL=$USE_GLES2 \
-D USE_RAPIDJSON:BOOL=$USE_RAPIDJSON \
-D USE_TBB:BOOL=$USE_TBB \
+ -D INSTALL_VTK=False \
+ -D CMAKE_CXX_FLAGS="-DVTK_MAJOR_VERSION=9" \
+ -D 3RDPARTY_VTK_LIBRARY_DIR:PATH="/usr/lib" \
+ -D 3RDPARTY_VTK_INCLUDE_DIR:PATH="/usr/include" \
-D USE_VTK:BOOL=$USE_VTK
-
+
cmake --build build_dir
}