summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2016-10-17 11:41:29 +0200
committerUffe Jakobsen2016-10-17 11:41:29 +0200
commite84f68960c710645c94e14a51f496792886091ee (patch)
tree2de5d080836b012b8a6e65ebb4c12a87660102af
parent62c6bc36a56303108aaf839a35a3e17bfe8be357 (diff)
downloadaur-e84f68960c710645c94e14a51f496792886091ee.tar.gz
apply local patch until upstream patch is applied
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--opencbm_usb_USB_LE16_TO_CPU_le16toh.patch29
3 files changed, 41 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e94328634f3a..555e32866b0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 16 13:46:30 UTC 2016
+# Mon Oct 17 09:36:24 UTC 2016
pkgbase = opencbm-git
pkgdesc = OpenCBM allows access to Commodore (C64) storage devices VIC 1540, 1541, 1570, 1571, or even 1581 floppy drive
- pkgver = r1226.e22583a
+ pkgver = r1229.dbeb7de
pkgrel = 1
url = http://sourceforge.net/projects/opencbm/
arch = i686
@@ -13,7 +13,9 @@ pkgbase = opencbm-git
depends = libusb
depends = libusb-compat
source = git+http://git.code.sf.net/p/opencbm/code
+ source = opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
md5sums = SKIP
+ md5sums = 460f571c2f1e2b80c10ade19a831fbed
pkgname = opencbm-git
diff --git a/PKGBUILD b/PKGBUILD
index 1cae284a187a..9a575e5d570b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Uffe Jakobsen <microtop@starion.dk>
#
pkgname=opencbm-git
-pkgver=r1226.e22583a
+pkgver=r1229.dbeb7de
pkgrel=1
epoch=
pkgdesc="OpenCBM allows access to Commodore (C64) storage devices VIC 1540, 1541, 1570, 1571, or even 1581 floppy drive"
@@ -27,8 +27,10 @@ options=()
install=
changelog=
noextract=()
-source=(git+http://git.code.sf.net/p/opencbm/code)
-md5sums=('SKIP')
+source=(git+http://git.code.sf.net/p/opencbm/code
+ opencbm_usb_USB_LE16_TO_CPU_le16toh.patch)
+md5sums=('SKIP'
+ '460f571c2f1e2b80c10ade19a831fbed')
pkgver() {
cd "${srcdir}/code"
@@ -41,7 +43,8 @@ prepare() {
build() {
cd "${srcdir}/code"
- make -f LINUX/Makefile opencbm plugin-xum1541
+ #make -f LINUX/Makefile opencbm plugin-xum1541
+ make -f LINUX/Makefile opencbm plugin
}
check() {
@@ -51,7 +54,7 @@ check() {
package() {
cd "${srcdir}/code"
mkdir -p "${pkgdir}/etc/udev/rules.d"
- make -f LINUX/Makefile PREFIX="/usr" MANDIR="/usr/share/man/man1" INFODIR="/usr/share/info" DESTDIR="${pkgdir}/" install install-plugin-xum1541
+ make -f LINUX/Makefile PREFIX="/usr" MANDIR="/usr/share/man/man1" INFODIR="/usr/share/info" DESTDIR="${pkgdir}/" install install-plugin
mv "${pkgdir}/etc/opencbm.conf" "${pkgdir}/etc/opencbm.conf.sample"
# remove kernel modules - not supported by this pkg
rm -rf "${pkgdir}/lib/modules"
diff --git a/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch b/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
new file mode 100644
index 000000000000..852ff252c3f5
--- /dev/null
+++ b/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
@@ -0,0 +1,29 @@
+commit 84b10fc7188de11fade4df963503080acbdb198c (HEAD -> refs/heads/usb_USB_LE16_TO_CPU_le16toh)
+Author: Uffe Jakobsen <microtop@starion.dk>
+AuthorDate: Sun Oct 16 17:02:22 2016 +0200
+Commit: Uffe Jakobsen <microtop@starion.dk>
+CommitDate: Sun Oct 16 17:02:51 2016 +0200
+
+ Linux: newer usb.h does not have USB_LE16_TO_CPU() macro anymore
+---
+:100644 100644 b9f6bd1... d7681cf... M xu1541/misc/usb_echo_test.c
+ xu1541/misc/usb_echo_test.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git xu1541/misc/usb_echo_test.c xu1541/misc/usb_echo_test.c
+index b9f6bd1..d7681cf 100644
+--- xu1541/misc/usb_echo_test.c
++++ xu1541/misc/usb_echo_test.c
+@@ -27,6 +27,12 @@ usb_dev_handle *handle = NULL;
+ #define QUIT_KEY
+ #endif
+
++// Linux: newer usb.h does not have USB_LE16_TO_CPU() macro anymore
++#ifndef USB_LE16_TO_CPU
++#include <endian.h>
++#define USB_LE16_TO_CPU(x) x=le16toh(x);
++#endif
++
+ /* send a number of 16 bit words to the xu1541 interface */
+ /* and verify that they are correctly returned by the echo */
+ /* command. This may be used to check the reliability of */