summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2015-07-17 17:47:10 -0700
committerMichael Hansen2015-07-17 17:47:10 -0700
commit148ac374e76f15e6196a38b3c5fa72be17b2e39a (patch)
tree19257a96bbb53a84c4b388023461bb4b9771c447
parentdba820aa7be08189ba14fc0374943a83aa847948 (diff)
parent436fb70e5ae8b0a0b3e5b511a6ba1d9ad4666ae4 (diff)
downloadaur-148ac374e76f15e6196a38b3c5fa72be17b2e39a.tar.gz
Merge pull request #1 from djlucas/openchange-2-3
Update provision-type-error patch for latest OpenChange
-rw-r--r--PKGBUILD4
-rw-r--r--openchange-provision-type-error.patch27
2 files changed, 26 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caffa87806ea..66dbf8e870d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openchange
_codename=VULCAN
pkgver=2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A portable, open source implementation of Microsoft Exchange server \
and Exchange protocols."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -25,7 +25,7 @@ source=("https://github.com/openchange/openchange/archive/${pkgname}-${pkgver}-$
sha256sums=('46ffdc779bb7bf6a823f6d1a78c5ca3f5548b981ad90164214a68279b403a05e'
'45bd19e2a5725a94692ae606086be6d57423375c9b1c0eb5322c6e09ef2b5fb3'
- '65dc742e95dd1bff1581ea3d76b4dfe8d01ca52ab5e64ffc80efc10417a2ff97'
+ '067d25b0442ab233f47fbfd32a56042fa161b3d0aa65081f222fddde3648c439'
'e3cfd2455a52d4b68153b3d546c70edbde5cf024ebcec1088a923aedaa938834')
# Used to be pkgname-pkgver-codename, but now we have two openchanges. WAT
diff --git a/openchange-provision-type-error.patch b/openchange-provision-type-error.patch
index 27dadcff4609..a7a2f7badf35 100644
--- a/openchange-provision-type-error.patch
+++ b/openchange-provision-type-error.patch
@@ -1,6 +1,6 @@
-diff -rupN a/python/openchange/mailbox.py b/python/openchange/mailbox.py
---- a/python/openchange/mailbox.py 2015-06-16 14:58:47.625735072 -0700
-+++ b/python/openchange/mailbox.py 2015-06-16 14:58:16.188582238 -0700
+diff -Naurp openchange-openchange-2.3-VULCAN-org/python/openchange/mailbox.py openchange-openchange-2.3-VULCAN/python/openchange/mailbox.py
+--- openchange-openchange-2.3-VULCAN-org/python/openchange/mailbox.py 2015-05-16 10:22:04.000000000 -0500
++++ openchange-openchange-2.3-VULCAN/python/openchange/mailbox.py 2015-07-17 18:48:13.929579900 -0500
@@ -498,7 +498,7 @@ class OpenChangeDBWithMysqlBackend(Mysql
def change_number(self):
if self._change_number is None:
@@ -10,3 +10,24 @@ diff -rupN a/python/openchange/mailbox.py b/python/openchange/mailbox.py
data = cur.fetchone()
if data:
self._change_number = data[0]
+diff -Naurp openchange-openchange-2.3-VULCAN-org/python/openchange/migration/__init__.py openchange-openchange-2.3-VULCAN/python/openchange/migration/__init__.py
+--- openchange-openchange-2.3-VULCAN-org/python/openchange/migration/__init__.py 2015-05-16 10:22:04.000000000 -0500
++++ openchange-openchange-2.3-VULCAN/python/openchange/migration/__init__.py 2015-07-17 18:49:02.877532654 -0500
+@@ -65,7 +65,7 @@ class MigrationManager(object):
+ """Create the table_name table if not exists
+ """
+ cur = self.db.cursor()
+- cur.execute("""SHOW TABLES LIKE %s""", self.table_name)
++ cur.execute("""SHOW TABLES LIKE %s""", (self.table_name,))
+ row = cur.fetchone()
+ if row is None or row[0] is None:
+ cur.execute("""CREATE TABLE IF NOT EXISTS `{0}` (
+@@ -87,7 +87,7 @@ class MigrationManager(object):
+ if self._version[app] is None:
+ cur = self.db.cursor()
+ cur.execute('SELECT MAX(version) FROM {0} WHERE app = %s'.format(self.table_name),
+- app)
++ (app,))
+ row = cur.fetchone()
+ if row and row[0]:
+ self._version[app] = int(row[0])