summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2015-06-16 14:52:35 -0700
committerMichael Hansen2015-06-16 14:52:35 -0700
commita1c29fe96409192228a716b3788541f8adebb8b3 (patch)
tree140a247528f5dada33b0899bd20f7cedb8e57e5b
parenta8714a0be820fa49cc87c3411bb0f8e766a483b7 (diff)
downloadaur-a1c29fe96409192228a716b3788541f8adebb8b3.tar.gz
Update for OpenChange 2.3
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e1ef73f0078..e40fbb6739a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
# Contributor: ngoonee <ngoonee.talk@gmail.com>
# Contributor: Adam Russell <adamlr6+arch@gmail.com>
pkgname=openchange
-_codename=NANOPROBE
-pkgver=2.2
-pkgrel=4
+_codename=VULCAN
+pkgver=2.3
+pkgrel=1
pkgdesc="A portable, open source implementation of Microsoft Exchange server \
and Exchange protocols. This package was originally created to support \
evolution-mapi and may not work for any other purpose."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://www.openchange.org"
license=('GPL3')
-depends=('samba>=4.2' 'libical' 'sqlite3' 'file' 'boost' 'python2' 'libmariadbclient')
-makedepends=('ccache' 'python2' 'docbook-xsl' 'libxslt')
+depends=('samba>=4.2.2' 'libical' 'sqlite3' 'file' 'boost' 'python2'
+ 'libmariadbclient' 'nanomsg>=0.5' 'libmemcached>=1.0.18')
+makedepends=('ccache' 'docbook-xsl' 'libxslt')
options=(!makeflags)
# Releases are mirrored at http://tracker.openchange.org/projects/openchange/files
-source=("https://github.com/openchange/openchange/archive/${pkgname}-${pkgver}-${_codename}.tar.gz"
- "openchange-samba42.patch")
+source=("https://github.com/openchange/openchange/archive/${pkgname}-${pkgver}-${_codename}.tar.gz")
-sha256sums=('84e22ea408b46e2c7ba2894af3b8514cc45434c85f55198a321dc5ea194ac6d8'
- '8e4c2afede896e16a74be87323412bdcad8173d6943107a0aab38c6b77860887')
+sha256sums=('46ffdc779bb7bf6a823f6d1a78c5ca3f5548b981ad90164214a68279b403a05e')
# Used to be pkgname-pkgver-codename, but now we have two openchanges. WAT
_srcsubdir="${pkgname}-${pkgname}-${pkgver}-${_codename}"
@@ -28,8 +27,6 @@ _srcsubdir="${pkgname}-${pkgname}-${pkgver}-${_codename}"
build() {
cd "${srcdir}/${_srcsubdir}"
- patch -p1 < "${srcdir}/openchange-samba42.patch"
-
PYTHON_CALLERS="$(find ${srcdir}/${_srcsubdir} -name '*.py')
$(find ${srcdir}/${_srcsubdir} -name 'configure.ac')
setup/openchange_newuser setup/openchange_provision