summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Mailänder2022-07-16 21:20:26 +0200
committerMatthias Mailänder2022-07-16 21:20:26 +0200
commite7a1313294f6515536682962dec8d1245f361573 (patch)
tree7058d9f5de361f949ddc69a2f6519e6f4fe541c1
parent2dc85731d127284f706b5c465e493cbd630ea681 (diff)
downloadaur-e7a1313294f6515536682962dec8d1245f361573.tar.gz
Update to 1.5.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--openchrom.desktop11
-rw-r--r--openchrom.pngbin0 -> 17257 bytes
4 files changed, 35 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aebc0abacd2f..0f5c71222113 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,14 @@
pkgbase = openchrom
- pkgdesc = Visualization and Analysis of mass spectrometric and chromatographic data
- pkgver = 1.4.0
- pkgrel = 2
+ pkgdesc = Visualization and analysis of mass spectrometric and chromatographic data
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://lablicate.com/platform/openchrom
arch = x86_64
license = EPL
- makedepends = maven
- makedepends = git
- depends = jdk8-openjdk
- depends = java-runtime
- depends = gtk2
- depends = libglvnd
- depends = libnet
- depends = libxtst
- depends = alsa-lib
- depends = python
- conflicts = openchrom-bin
- source = git+https://github.com/OpenChrom/openchrom.git
- source = git+https://github.com/eclipse/chemclipse.git
+ license = custom: commercial
+ source = https://products.lablicate.com/openchrom/1.5.0/openchrom-lablicate_linux.x86_64_1.5.0.tar.gz
+ source = openchrom.desktop
sha256sums = SKIP
sha256sums = SKIP
pkgname = openchrom
-
diff --git a/PKGBUILD b/PKGBUILD
index 8d8498cb7363..4caa6cefae90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Matthias Mailänder <matthias at mailaender dot name>
pkgname=openchrom
-pkgver=1.4.0
-pkgrel=2
-pkgdesc="Visualization and Analysis of mass spectrometric and chromatographic data"
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Visualization and analysis of mass spectrometric and chromatographic data"
arch=("x86_64")
url="https://lablicate.com/platform/openchrom"
-license=('EPL')
-depends=('jdk8-openjdk' 'java-runtime' 'gtk2' 'libglvnd' 'libnet' 'libxtst' 'alsa-lib'
- 'python')
-makedepends=('maven' 'git')
-conflicts=("$pkgname-bin")
-source=("git+https://github.com/OpenChrom/openchrom.git"
- "git+https://github.com/eclipse/chemclipse.git")
+license=('EPL' 'custom: commercial')
+# Don't build from source, because otherwise proprietary file converters are missing.
+source=("https://products.lablicate.com/openchrom/${pkgver}/openchrom-lablicate_linux.x86_64_${pkgver}.tar.gz"
+ "openchrom.desktop"
+ "openchrom.png")
+# Avoid checksums, because minor release overwrite without change in versioning.
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
-build() {
- cd "$srcdir"
- mvn -f $pkgname/$pkgname/releng/net.openchrom.aggregator/pom.xml install
-}
-
package() {
- cd "$pkgdir"
- install -dm755 {usr/bin,opt/openchrom}
- cd "$srcdir/openchrom/openchrom/products/net.openchrom.rcp.compilation.community.product/target/products/net.openchrom.rcp.compilation.community.product.id/linux/gtk/$CARCH"
- cp -r * "$pkgdir/opt/openchrom"
- cd "$pkgdir/opt"
- sed -i "s@$srcdir@@g" openchrom/p2/org.eclipse.equinox.p2.engine/.settings/*
- chmod -R 755 openchrom
- ln -sf /opt/openchrom/openchrom ../usr/bin
+ install -d "${pkgdir}/usr/lib/openchrom"
+ cp -r configuration features p2 plugins readme artifacts.xml openchrom openchrom.ini "${pkgdir}/usr/lib/openchrom"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/openchrom/openchrom" "${pkgdir}/usr/bin/openchrom"
+
+ install -Dm0644 "openchrom.desktop" "${pkgdir}/usr/share/applications/openchrom.desktop"
+ install -Dm0644 "openchrom.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/openchrom.png"
}
diff --git a/openchrom.desktop b/openchrom.desktop
new file mode 100644
index 000000000000..6df6af2f5b2d
--- /dev/null
+++ b/openchrom.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=OpenChrom
+GenericName=Chromatography Data System
+Icon=openchrom
+Exec=openchrom %f
+Comment=Visualization and Analysis of Chromatography, Spectrometry and Spectroscopy Data
+Categories=Education;Chemistry;
+Terminal=false
+StartupWMClass=openchrom
diff --git a/openchrom.png b/openchrom.png
new file mode 100644
index 000000000000..210d948c684d
--- /dev/null
+++ b/openchrom.png
Binary files differ