summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMārtiņš Možeiko2022-01-11 23:05:45 -0800
committerMārtiņš Možeiko2022-01-11 23:05:45 -0800
commit0aa07ef3327060f6b092abd570a4c362bb987a34 (patch)
treebe89ffe45935fa93546668022d09fd5932254a88
downloadaur-0aa07ef3327060f6b092abd570a4c362bb987a34.tar.gz
version 1.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8f56821e781
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = opencl-caps-viewer
+ pkgdesc = OpenCL Hardware Capability Viewer
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://opencl.gpuinfo.org/
+ arch = x86_64
+ license = GPL2
+ depends = opencl-icd-loader
+ depends = qt5-base
+ source = opencl-caps-viewer::git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=1.00
+ source = git+https://github.com/KhronosGroup/OpenCL-Headers.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = opencl-caps-viewer
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e08322219f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+opencl-caps-viewer
+OpenCL-Headers
+pkg
+src
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d74e2726fd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
+pkgname=opencl-caps-viewer
+pkgver=1.0
+_pkgtag=1.00
+pkgrel=1
+pkgdesc="OpenCL Hardware Capability Viewer"
+arch=("x86_64")
+depends=("opencl-icd-loader" "qt5-base")
+url="https://opencl.gpuinfo.org/"
+license=("GPL2")
+
+source=("opencl-caps-viewer::git+https://github.com/SaschaWillems/OpenCLCapsViewer.git#tag=${_pkgtag}"
+ "git+https://github.com/KhronosGroup/OpenCL-Headers.git")
+
+sha256sums=("SKIP"
+ "SKIP")
+
+prepare() {
+ cd "$srcdir/${pkgname}"
+ git submodule init
+ git config submodule.OpenCL-Headers.url "$srcdir/OpenCL-Headers"
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ qmake
+ make
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/bin
+ install -m755 "${srcdir}/${pkgname}"/OpenCLCapsViewer "${pkgdir}"/usr/bin/OpenCLCapsViewer
+
+ install -dm755 "$pkgdir"/usr/share/applications
+ install -m644 "${srcdir}/${pkgname}"/OpenCLCapsViewer.desktop "${pkgdir}"/usr/share/applications/OpenCLCapsViewer.desktop
+
+ install -dm755 "${pkgdir}"/usr/share/icons
+ install -m644 "${srcdir}/${pkgname}"/Resources/icon.png "${pkgdir}"/usr/share/icons/openclCapsViewer.png
+}